summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-03 21:56:53 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-03 21:56:53 -0500
commitbb557c9ac19ab01cdf621c3fac887750981feb77 (patch)
treee3a059a9af2aaf17ee27e63e2a9dcc8eb48e51bc
parent117a0de2406424a5fd85ae07f769a2aea8aab45e (diff)
downloadguix-patches-bb557c9ac19ab01cdf621c3fac887750981feb77.tar
guix-patches-bb557c9ac19ab01cdf621c3fac887750981feb77.tar.gz
build/python: Handle FileNotFoundError exception in sanity-check.py.
This exception was thrown while running the sanity-check on the python-isort package, which doesn't make use of a setuptools-based build system but rather of a PEP 517 compliant one. * gnu/packages/aux-files/python/sanity-check.py: Handle the FileNotFoundError whe attempting to read the 'top_level.txt' metadata file of the package. Remove extraneous 'continue' statement.
-rw-r--r--gnu/packages/aux-files/python/sanity-check.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/aux-files/python/sanity-check.py b/gnu/packages/aux-files/python/sanity-check.py
index 355e55b240..83b6d583ca 100644
--- a/gnu/packages/aux-files/python/sanity-check.py
+++ b/gnu/packages/aux-files/python/sanity-check.py
@@ -51,8 +51,10 @@ for dist in ws:
# Try to load top level modules. This should not have any side-effects.
try:
metalines = dist.get_metadata_lines('top_level.txt')
- except KeyError:
+ except (KeyError, FileNotFoundError):
# distutils (i.e. #:use-setuptools? #f) will not install any metadata.
+ # This file is also missing for packages built using a PEP 517 builder
+ # such as poetry.
print('WARNING: cannot determine top-level modules')
continue
for name in metalines:
@@ -70,7 +72,6 @@ for dist in ws:
print('ERROR:')
traceback.print_exc(file=sys.stdout)
ret = 1
- continue
# Try to load entry points of console scripts too, making sure they
# work. They should be removed if they don't. Other groups may not be