summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2023-10-31 20:34:35 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-11-02 18:58:11 +0100
commita94ec292d21a2171db741ef748ed4c8b3ef65ada (patch)
tree8d343ae35f29ea84ab96b9cd19af81c458817f9e
parentea51a3885c56c669f8558592d0ac13a1aae0e548 (diff)
downloadguix-patches-a94ec292d21a2171db741ef748ed4c8b3ef65ada.tar
guix-patches-a94ec292d21a2171db741ef748ed4c8b3ef65ada.tar.gz
gnu: feedbackd: Update to 0.2.1.
* gnu/packages/patches/feedbackd-use-system-gmobile.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it here. * gnu/packages/gnome.scm (feedbackd): Update to 0.2.1. [origin]<patches>: Add “feedbackd-use-system-gmobile.patch”. <snippet>: Remove the gmobile submodule. [inputs]: Add gmobile. Change-Id: I06521c1673efb6aea1d163410fdf3d0206b57d8a Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gnome.scm12
-rw-r--r--gnu/packages/patches/feedbackd-use-system-gmobile.patch42
3 files changed, 52 insertions, 3 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 92b56289f2..fc3e36fc18 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1155,6 +1155,7 @@ dist_patch_DATA = \
%D%/packages/patches/fasthenry-spFactor.patch \
%D%/packages/patches/fbreader-curl-7.62.patch \
%D%/packages/patches/fbreader-fix-icon.patch \
+ %D%/packages/patches/feedbackd-use-system-gmobile.patch \
%D%/packages/patches/fenics-dolfin-algorithm.patch \
%D%/packages/patches/fenics-dolfin-demo-init.patch \
%D%/packages/patches/fenics-dolfin-boost.patch \
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6761ffa5dc..0b461e4296 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -12945,7 +12945,7 @@ host to avoid parser overhead and memory-allocator fragmentation.")
(define-public feedbackd
(package
(name "feedbackd")
- (version "0.0.0+git20200527")
+ (version "0.2.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -12954,12 +12954,18 @@ host to avoid parser overhead and memory-allocator fragmentation.")
(file-name (git-file-name name version))
(sha256
(base32
- "1wbkzxnqjydfgjvp7vz4ghczcz740zcb1yn90cb6gb5md4n6qx2y"))))
+ "1acwpb8cgzyvzriphrb42k3d7njwcn88j66i5wz75yx2sbfaf93q"))
+ (patches
+ (search-patches "feedbackd-use-system-gmobile.patch"))
+ (snippet
+ #~(begin
+ (use-modules (guix build utils))
+ (delete-file-recursively "subprojects")))))
(build-system meson-build-system)
(native-inputs
(list `(,glib "bin") gobject-introspection pkg-config vala))
(inputs
- (list dbus gsound json-glib libgudev))
+ (list dbus gmobile gsound json-glib libgudev))
(propagated-inputs
(list glib)) ; in Requires of libfeedback-0.0.pc
(synopsis "Haptic/visual/audio feedback via DBus")
diff --git a/gnu/packages/patches/feedbackd-use-system-gmobile.patch b/gnu/packages/patches/feedbackd-use-system-gmobile.patch
new file mode 100644
index 0000000000..f0a0449472
--- /dev/null
+++ b/gnu/packages/patches/feedbackd-use-system-gmobile.patch
@@ -0,0 +1,42 @@
+From af9e72124b12ca481fd3592f9c8ea2649f7e4c80 Mon Sep 17 00:00:00 2001
+Message-ID: <af9e72124b12ca481fd3592f9c8ea2649f7e4c80.1698775513.git.vivien@planete-kraus.eu>
+From: Vivien Kraus <vivien@planete-kraus.eu>
+Date: Sun, 29 Oct 2023 19:12:27 +0100
+Subject: [PATCH] Look for a system-installed gmobile first.
+
+Meson lets projects use a dependency with fallback to a submodule, in
+case the dependency is not installed.
+
+* meson.build (gmobile_subp): Convert to a dependency with subproject
+fallback.
+---
+I am waiting for Purism to approve my account before I can report this.
+
+ meson.build | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index 8725e76..e5504be 100644
+--- a/meson.build
++++ b/meson.build
+@@ -14,13 +14,13 @@ gio_unix = dependency('gio-unix-2.0', version: '>=2.50.0')
+ glib = dependency('glib-2.0', version: '>=2.50.0')
+ if get_option('daemon')
+ gobject = dependency('gobject-2.0', version: '>=2.50.0')
+- gmobile_subp = subproject('gmobile',
++ gmobile = dependency('gmobile',
++ fallback: ['gmobile', 'gmobile_dep'],
+ default_options: [
+ 'examples=false',
+ 'gtk_doc=false',
+ 'tests=false',
+ ])
+- gmobile = gmobile_subp.get_variable('gmobile_dep')
+ gsound = dependency('gsound')
+ gudev = dependency('gudev-1.0', version: '>=232')
+ json_glib = dependency('json-glib-1.0')
+
+base-commit: 853bd6d7ea8455efea063ba7c4f29ce8c203285f
+--
+2.41.0
+