summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Nikkilä <hello@lnikki.la>2024-03-31 06:14:26 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-04-02 16:19:16 +0300
commita88b0c23c391bb521c8267646bba4108aea972db (patch)
tree4151bf47c30ccce4b971437fc22e87160ac1f023
parentba76b27de91e1ca950fda9e9b6995761f9f28add (diff)
downloadguix-patches-a88b0c23c391bb521c8267646bba4108aea972db.tar
guix-patches-a88b0c23c391bb521c8267646bba4108aea972db.tar.gz
gnu: gtk: Fix tests on aarch64.
* gnu/packages/gtk.scm (gtk)[arguments]<#:configure-flags>: Skip more failing tests known to fail. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Change-Id: I34d0f7521224b41072fcc0c35321935d1db927e0
-rw-r--r--gnu/packages/gtk.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 9252315fd2..da56834df6 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1157,7 +1157,12 @@ application suites.")
"--no-suite=failing"
"--no-suite=flaky"
"--no-suite=headless" ; requires mutter…
- "--no-suite=gsk-compare-broadway")
+ "--no-suite=gsk-compare-broadway"
+ ;; These seem to fail on aarch64, and Debian has
+ ;; also disabled these, see:
+ ;; https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1050075
+ "--no-suite=wayland_failing"
+ "--no-suite=wayland_gles_failing")
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'generate-gdk-pixbuf-loaders-cache-file