summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-06 15:15:37 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-28 22:22:14 -0400
commita133212daf882335fc41b0cdfd775bb28f4a1228 (patch)
tree51947b2c91e5409b916e91b12772fd9ccf1ecfc2
parent860fc8b895a64278547053ad08c56110f59cec3c (diff)
downloadguix-patches-a133212daf882335fc41b0cdfd775bb28f4a1228.tar
guix-patches-a133212daf882335fc41b0cdfd775bb28f4a1228.tar.gz
gnu: Remove ruby-protobuf-cucumber.
The package is no longer used by ruby-cucumber-messages, its sole user. It is unmaintained. * gnu/packages/protobuf.scm (ruby-protobuf-cucumber): Delete variable.
-rw-r--r--gnu/packages/protobuf.scm17
1 files changed, 0 insertions, 17 deletions
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index b580f8b2a7..82c5b7b5f8 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -589,20 +589,3 @@ source files.")
(description "Protobuf is an implementation of Google's Protocol Buffers
in pure Ruby.")
(license license:expat)))
-
-;;; This is a modified ruby-protobuf package used by ruby-cucumber-messages
-;;; until https://github.com/ruby-protobuf/protobuf/pull/411 and
-;;; https://github.com/ruby-protobuf/protobuf/pull/415 are merged upstream.
-(define-public ruby-protobuf-cucumber
- (hidden-package
- (package
- (inherit ruby-protobuf)
- (name "ruby-protobuf-cucumber")
- (version "3.10.8")
- (source
- (origin
- (method url-fetch)
- (uri (rubygems-uri "protobuf-cucumber" version))
- (sha256
- (base32
- "1rd6naabhpfb1i5dr6fp5mqwaawsx0mqm73h5ycwkgbm1n2si872")))))))