summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-01-10 20:14:32 +0800
committerMathieu Othacehe <othacehe@gnu.org>2024-01-10 15:29:11 +0100
commita126e8120d30a3f66149f307a922acd77cde9d5a (patch)
treeb0fa9934c423dd49b70fcf9203a97fff1dd12179
parent6401efb55498f9b6354e51586857fe7a3f988c33 (diff)
downloadguix-patches-a126e8120d30a3f66149f307a922acd77cde9d5a.tar
guix-patches-a126e8120d30a3f66149f307a922acd77cde9d5a.tar.gz
gnu: mesa: Fix cross-compilation.
* gnu/packages/gl.scm(mesa)[arguments]<#:phases>: When cross-compiling, force the use of the cmake method to find llvm. Change-Id: I27f6f4d9d71028c15588eeade48d3a918c042b9c Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/gl.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 7998142b4d..49dc878c02 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -421,6 +421,9 @@ svga,swrast,virgl,zink")))
;; When cross compiling, we use cmake to find llvm, not
;; llvm-config, because llvm-config cannot be executed
;; see https://github.com/llvm/llvm-project/issues/58984
+ (substitute* "meson.build"
+ (("method : host_machine\\.system.*")
+ "method : 'cmake',\n"))
(setenv "CMAKE"
(search-input-file
native-inputs "/bin/cmake")))))