summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2022-02-08 19:05:40 +0100
committerBrice Waegeneire <brice@waegenei.re>2022-02-12 14:08:19 +0100
commit9c8f68f4796f23c11173fa3f90c69bc85b224ac6 (patch)
tree19cde73d6c4b156de39c24ff24fdc4045a6aeb17
parent47eb897bd377f87854335a6d0cc711b94cb8589e (diff)
downloadguix-patches-9c8f68f4796f23c11173fa3f90c69bc85b224ac6.tar
guix-patches-9c8f68f4796f23c11173fa3f90c69bc85b224ac6.tar.gz
gnu: protonvpn-cli: Do not try to wrap the wrapper.
* gnu/packages/vpn.scm (protonvpn-cli)[arguments]: Try to wrap the original program, and not the wrapper, as wrap-program handles that properly.
-rw-r--r--gnu/packages/vpn.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 7f1d10d1eb..9fd0e4493d 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2021 Domagoj Stolfa <ds815@gmx.com>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 jgart <jgart@dismail.de>
+;;; Copyright © 2022 Josselin Poiret <josselin.poiret@protonmail.ch>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -753,7 +754,7 @@ traversing network address translators (@dfn{NAT}s) and firewalls.")
;; Wrap entrypoint with paths to its hard dependencies.
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((entrypoint (string-append (assoc-ref outputs "out")
- "/bin/.protonvpn-real")))
+ "/bin/protonvpn")))
(wrap-program entrypoint
#:sh (search-input-file inputs "bin/bash")
`("PATH" ":" prefix