summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-06-01 16:53:01 +0200
committerLudovic Courtès <ludo@gnu.org>2022-06-04 12:04:24 +0200
commit8eb17cebc1027b5ae1c4047c704b92ad73b783fd (patch)
tree2c93729a8d0f11ac1002f4cc819d84caf85d7cbd
parent3f83c0b7c7b4761062184a01f0977199957383ad (diff)
downloadguix-patches-8eb17cebc1027b5ae1c4047c704b92ad73b783fd.tar
guix-patches-8eb17cebc1027b5ae1c4047c704b92ad73b783fd.tar.gz
home: services: Add 'lookup-home-service-types' procedure.
* gnu/home/services.scm (lookup-home-service-types): New procedure. * tests/home-services.scm: New file. * Makefile.am (SCM_TESTS): Add it.
-rw-r--r--Makefile.am1
-rw-r--r--gnu/home/services.scm12
-rw-r--r--tests/home-services.scm46
3 files changed, 59 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f585d00b86..89bc03c9a2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -497,6 +497,7 @@ SCM_TESTS = \
tests/gremlin.scm \
tests/hackage.scm \
tests/home-import.scm \
+ tests/home-services.scm \
tests/http-client.scm \
tests/import-git.scm \
tests/import-github.scm \
diff --git a/gnu/home/services.scm b/gnu/home/services.scm
index 8284a4f3fc..5ee3357792 100644
--- a/gnu/home/services.scm
+++ b/gnu/home/services.scm
@@ -33,6 +33,7 @@
#:use-module (guix modules)
#:use-module (srfi srfi-1)
#:use-module (ice-9 match)
+ #:use-module (ice-9 vlist)
#:export (home-service-type
home-profile-service-type
@@ -50,6 +51,7 @@
xdg-data-files-directory
fold-home-service-types
+ lookup-home-service-types
home-provenance
%initialize-gettext)
@@ -605,3 +607,13 @@ environment, and its configuration file, when available.")))
(define* (fold-home-service-types proc seed)
(fold-service-types proc seed (all-home-service-modules)))
+
+(define lookup-home-service-types
+ (let ((table
+ (delay (fold-home-service-types (lambda (type result)
+ (vhash-consq (service-type-name type)
+ type result))
+ vlist-null))))
+ (lambda (name)
+ "Return the list of services with the given NAME (a symbol)."
+ (vhash-foldq* cons '() name (force table)))))
diff --git a/tests/home-services.scm b/tests/home-services.scm
new file mode 100644
index 0000000000..e13733cabd
--- /dev/null
+++ b/tests/home-services.scm
@@ -0,0 +1,46 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (test-home-services)
+ #:use-module (gnu services)
+ #:use-module (gnu home services)
+ #:use-module (guix diagnostics)
+ #:use-module (srfi srfi-1)
+ #:use-module (srfi srfi-64)
+ #:use-module (ice-9 match))
+
+(test-begin "home-services")
+
+(test-assert "fold-home-service-types"
+ (match (fold-home-service-types cons '())
+ (() #f)
+ (lst (and (every service-type? lst)
+ (every (lambda (type)
+ (let ((location (service-type-location type)))
+ (string-contains (location-file location)
+ "gnu/home")))
+ lst)))))
+
+(test-eq "lookup-service-types"
+ home-files-service-type
+ (and (null? (lookup-home-service-types 'does-not-exist-at-all))
+ (match (lookup-home-service-types 'home-files)
+ ((one) one)
+ (x x))))
+
+(test-end)