summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-04-04 21:34:15 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-04-05 00:53:17 +0200
commit8e2a1a0e8d1f896edf0ab6d9ea6b7216ae244253 (patch)
treeb11334bd86c77f8a6d6bb2fd34adfea0c6483b7a
parent5e90ee2cf472a35953122f7067bbb185062208f5 (diff)
downloadguix-patches-8e2a1a0e8d1f896edf0ab6d9ea6b7216ae244253.tar
guix-patches-8e2a1a0e8d1f896edf0ab6d9ea6b7216ae244253.tar.gz
gnu: Add java-autocomplete.
* gnu/packages/textutils.scm (java-autocomplete): New variable. Change-Id: Ied62d45ab53fca84d448652cce5e82d971f41703
-rw-r--r--gnu/packages/textutils.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 0ad0638771..484ba6939b 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -976,6 +976,48 @@ efficient, and can be used in any application that needs to edit or view
source code.")
(license license:bsd-3)))
+(define-public java-autocomplete
+ (package
+ (name "java-autocomplete")
+ (version "3.3.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bobbylight/AutoComplete")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ksa3k3xkdjpyq9sbsvchyhfzzpb67pv8xzbpljj8rqilgk8ysy0"))))
+ (build-system ant-build-system)
+ (arguments
+ (list
+ #:tests? #false ;needs junit5
+ #:jar-name "autocomplete.jar"
+ #:source-dir "AutoComplete/src/main/java"
+ #:test-dir "AutoComplete/src/test"
+ #:phases
+ '(modify-phases %standard-phases
+ (add-before 'build 'copy-resources
+ (lambda _
+ (copy-recursively "AutoComplete/src/main/resources" "build/classes"))))))
+ (propagated-inputs
+ (list java-rsyntaxtextarea))
+ (native-inputs
+ (list java-hamcrest-core))
+ (home-page "https://github.com/bobbylight/AutoComplete")
+ (synopsis "Text completion library")
+ (description "AutoComplete is a library allowing you to add IDE-like
+auto-completion (aka \"code completion\" or \"Intellisense\") to any Swing
+JTextComponent. Special integration is added for @code{RSyntaxTextArea},
+since this feature is commonly needed when editing source code. Features
+include: Drop-down completion choice list. Optional companion \"description\"
+window, complete with full HTML support and navigable with hyperlinks.
+Optional parameter completion assistance for functions and methods, ala
+Eclipse and NetBeans. Completion information is typically specified in an XML
+file, but can even be dynamic.")
+ (license license:bsd-3)))
+
;; We use the sources from git instead of the tarball from pypi, because the
;; latter does not include the Cython source file from which bycython.cpp is
;; generated.