summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-11-25 02:24:41 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-25 01:04:17 -0500
commit87e96b69aae4d02fdbef3eb6b9283e61a96a449b (patch)
tree8daaa61052312e8cc1334da672f3c531ddbe7a50
parentf2bdd5a43d4aa8c5eeb0923308dc97c969599bda (diff)
downloadguix-patches-87e96b69aae4d02fdbef3eb6b9283e61a96a449b.tar
guix-patches-87e96b69aae4d02fdbef3eb6b9283e61a96a449b.tar.gz
gnu: julia: Disable broken tests.
* gnu/packages/julia.scm (julia)[arguments]: Disable broken tests. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/julia.scm19
1 files changed, 16 insertions, 3 deletions
diff --git a/gnu/packages/julia.scm b/gnu/packages/julia.scm
index aff7e1a66f..d0329a96a1 100644
--- a/gnu/packages/julia.scm
+++ b/gnu/packages/julia.scm
@@ -358,8 +358,8 @@ libraries. It is also a bit like @code{ldd} and @code{otool -L}.")
;; Dates/io tests fail on master when networking is unavailable
;; https://github.com/JuliaLang/julia/issues/34655
(substitute* "stdlib/Dates/test/io.jl"
- (("\"Dates.Date") "\"Date")
- (("\"Dates.Time") "\"Time"))
+ (("using Dates") "import Dates
+using Dates: @dateformat_str, Date, DateTime, DateFormat, Time"))
;; Upstream bug I found when packaging
;; https://github.com/JuliaLang/julia/issues/35785
(substitute* "test/file.jl"
@@ -382,7 +382,20 @@ libraries. It is also a bit like @code{ldd} and @code{otool -L}.")
;(setenv "LC_ALL" "en_US.utf8")
(substitute* "test/cmdlineargs.jl"
(("test v\\[3") "test_broken v[3")
- (("test isempty\\(v\\[3") "test_broken isempty(v[3"))))
+ (("test isempty\\(v\\[3") "test_broken isempty(v[3"))
+ ;; These tests randomly fails because they depend on CPU.
+ (substitute* "stdlib/LinearAlgebra/test/matmul.jl"
+ ;; Fixed in v1.6.4 (see:
+ ;; https://github.com/JuliaLang/julia/blob/v1.6.4/
+ ;; stdlib/LinearAlgebra/test/matmul.jl#L155).
+ (("@test mul\\!\\(C, vf, transpose\\(vf\\), 2, 3\\)\
+ == 2vf\\*vf' \\.\\+ 3C0")
+ "@test mul!(C, vf, transpose(vf), 2, 3) ≈ 2vf*vf' .+ 3C0"))
+ (substitute* "test/math.jl"
+ ;; @test_broken cannot be used because if the test randomly
+ ;; passes, then it also raises an error.
+ (("@test isinf\\(log1p\\(-one\\(T\\)\\)\\)")
+ " "))))
(add-before 'install 'symlink-libraries
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((link