summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-04-03 11:54:12 -0400
committerLudovic Courtès <ludo@gnu.org>2022-04-05 20:41:40 +0200
commit86ee397e2658de915d79fd4ad6d2217b941b4682 (patch)
treebb54b243e5cb29d2f8edef164601f2c2ce5e123a
parentc9cca908fa79c51ea3bc8ed2aa6c11d1b1868765 (diff)
downloadguix-patches-86ee397e2658de915d79fd4ad6d2217b941b4682.tar
guix-patches-86ee397e2658de915d79fd4ad6d2217b941b4682.tar.gz
gnu: pantheon-calculator: Update to 1.7.2.
* gnu/packages/pantheon.scm (pantheon-calculator): Update to 1.7.2. [arguments]: Remove trailing boolean. [inputs]: Use guix style and add libhandy input. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/pantheon.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/pantheon.scm b/gnu/packages/pantheon.scm
index 756db94144..acb19a3ef8 100644
--- a/gnu/packages/pantheon.scm
+++ b/gnu/packages/pantheon.scm
@@ -67,7 +67,7 @@ in apps built for the Pantheon desktop.")
(define-public pantheon-calculator
(package
(name "pantheon-calculator")
- (version "1.5.5")
+ (version "1.7.2")
(source
(origin
(method git-fetch)
@@ -77,7 +77,7 @@ in apps built for the Pantheon desktop.")
(file-name (git-file-name name version))
(sha256
(base32
- "1csxsr2c8qvl97xz9ahwn91z095nzgr0i1mbcb1spljll2sr9lkj"))))
+ "11rwwi6nlhwpcm29dn2mbz0239nfjdwlqlqbchm0j9sr1ypifk2k"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
@@ -85,13 +85,13 @@ in apps built for the Pantheon desktop.")
(modify-phases %standard-phases
(add-after 'unpack 'disable-schema-cache-generation
(lambda _
- (setenv "DESTDIR" "/")
- #t)))))
+ (setenv "DESTDIR" "/"))))))
(inputs
- `(("granite" ,granite)
- ("glib" ,glib)
- ("gtk" ,gtk+)
- ("libgee" ,libgee)))
+ (list granite
+ glib
+ gtk+
+ libgee
+ libhandy))
(native-inputs
`(("cmake" ,cmake)
("glib:bin" ,glib "bin") ; for glib-compile-schemas