summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2022-01-15 14:59:42 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-17 00:18:23 +0100
commit863b7b7dd7059e9e2c78f89b501919042159eccd (patch)
tree1b0521a40dda91b8df120c8afec32d836f8c884a
parent4527743f0a2d58d7cdf5abdd74016908eecd66a6 (diff)
downloadguix-patches-863b7b7dd7059e9e2c78f89b501919042159eccd.tar
guix-patches-863b7b7dd7059e9e2c78f89b501919042159eccd.tar.gz
gnu: pantalaimon: Add needed inputs
* gnu/packages/matrix.scm (pantalaimon) <propagated-inputs>: Add python-dbus, python-notify2, python-pydbus, and python-pygobject. <arguments>: Run sanity-check phase. Co-authored-by: Aleksandr Vityazev <avityazev@posteo.org> Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/matrix.scm20
1 files changed, 13 insertions, 7 deletions
diff --git a/gnu/packages/matrix.scm b/gnu/packages/matrix.scm
index e2c27f5a4c..5f94eb2075 100644
--- a/gnu/packages/matrix.scm
+++ b/gnu/packages/matrix.scm
@@ -3,6 +3,8 @@
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2022 Aleksandr Vityazev <avityazev@posteo.org>
+;;; Copyright © 2022 Morgan Smith <Morgan.J.Smith@outlook.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24,6 +26,7 @@
#:use-module (gnu packages check)
#:use-module (gnu packages crypto)
#:use-module (gnu packages databases)
+ #:use-module (gnu packages glib)
#:use-module (gnu packages monitoring)
#:use-module (gnu packages python-build)
#:use-module (gnu packages python-check)
@@ -257,25 +260,28 @@ fledged batteries-included asyncio layer using aiohttp.")
(lambda* (#:key tests? inputs outputs #:allow-other-keys)
(when tests?
(add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-vv" "tests"))))
- ;; XXX: The sanity check trips on optional GUI libraries for the
- ;; panctl command.
- (delete 'sanity-check))))
+ (invoke "pytest" "-vv" "tests")))))))
(native-inputs
- (list python-pytest python-faker python-pytest-aiohttp
- python-aioresponses))
+ (list python-aioresponses
+ python-faker
+ python-pytest
+ python-pytest-aiohttp))
(propagated-inputs
(list python-aiohttp
python-appdirs
python-attrs
python-cachetools
python-click
+ python-dbus
python-janus
python-keyring
python-logbook
python-matrix-nio
+ python-notify2
python-peewee
- python-prompt-toolkit))
+ python-prompt-toolkit
+ python-pydbus
+ python-pygobject))
(home-page "https://github.com/matrix-org/pantalaimon")
(synopsis "Matrix proxy daemon that adds E2E encryption capabilities")
(description