summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-08 17:33:59 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-08 20:19:23 -0500
commit7f212c550457747861fa477ba3a1737339ddb6d0 (patch)
treed6749dee4515c178f3166ab937b68b1264efee60
parentbd53dfa6df79075493fbe55aa9ca9a7affb7ce1b (diff)
downloadguix-patches-7f212c550457747861fa477ba3a1737339ddb6d0.tar
guix-patches-7f212c550457747861fa477ba3a1737339ddb6d0.tar.gz
gnu: python-robotframework: Update to 4.1.3.
* gnu/packages/python-xyz.scm (python-robotframework): Update to 4.1.3. [phases]{check}: Honor TESTS?. Search tzdata in both native-inputs or inputs, for cross-compilation.
-rw-r--r--gnu/packages/python-xyz.scm30
1 files changed, 16 insertions, 14 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2500ffa7ac..dcb36a55bd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4677,7 +4677,7 @@ ecosystem, but can naturally be used also by other projects.")
(define-public python-robotframework
(package
(name "python-robotframework")
- (version "4.1.2")
+ (version "4.1.3")
;; There are no tests in the PyPI archive.
(source
(origin
@@ -4687,7 +4687,7 @@ ecosystem, but can naturally be used also by other projects.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0s6lakbd8h1pa4lfdj18sm13gpywszgpcns4hz026a4kam787kby"))
+ (base32 "0j71awmfkwk7prz82kr1zbcl3nrih3396sshrygnqlrdjmgivd3p"))
(patches (search-patches
"python-robotframework-source-date-epoch.patch"))))
(build-system python-build-system)
@@ -4703,23 +4703,25 @@ ecosystem, but can naturally be used also by other projects.")
(copy-recursively "doc/libraries"
(string-append doc "/libraries")))))
(replace 'check
- (lambda* (#:key inputs #:allow-other-keys)
- ;; Some tests require timezone data. Otherwise, they
- ;; look up /etc/localtime, which doesn't exist, and fail
- ;; with:
- ;;
- ;; OverflowError: mktime argument out of range
- (setenv "TZDIR"
- (search-input-directory inputs "share/zoneinfo"))
- (setenv "TZ" "Europe/Paris")
-
- (invoke "python" "utest/run.py"))))))
+ (lambda* (#:key native-inputs inputs tests?
+ #:allow-other-keys)
+ (when tests?
+ ;; Some tests require timezone data. Otherwise, they
+ ;; look up /etc/localtime, which doesn't exist, and
+ ;; fail with:
+ ;;
+ ;; OverflowError: mktime argument out of range
+ (setenv "TZDIR"
+ (search-input-directory
+ (or native-inputs inputs) "share/zoneinfo"))
+ (setenv "TZ" "Europe/Paris")
+ (invoke "python" "utest/run.py")))))))
(native-inputs
`(("python-docutils" ,python-docutils)
("python-jsonschema" ,python-jsonschema)
("python-invoke" ,python-invoke)
("python-rellu" ,python-rellu)
- ("python:tk" ,python "tk") ;used when building the HTML doc
+ ("python:tk" ,python "tk") ;used when building the HTML doc
("tzdata" ,tzdata-for-tests)))
(outputs '("out" "doc"))
(home-page "https://robotframework.org")