summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-02-18 20:31:57 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-02-18 21:11:56 +0100
commit7ec692587a20a248e6b94fffc214ab152e7907d3 (patch)
tree24636f847e84b2ab80fca7172a989949f9d8677f
parent48e5c3bd290da7e796197f972645ae7a19a5677c (diff)
downloadguix-patches-7ec692587a20a248e6b94fffc214ab152e7907d3.tar
guix-patches-7ec692587a20a248e6b94fffc214ab152e7907d3.tar.gz
gnu: Add r-lambertw.
* gnu/packages/cran.scm (r-lambertw): New variable.
-rw-r--r--gnu/packages/cran.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 174c85a964..1f4f55f038 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5576,6 +5576,42 @@ selection, as well as methods for retrieving coordinates, for subsetting,
print, summary, etc.")
(license license:gpl2+)))
+(define-public r-lambertw
+ (package
+ (name "r-lambertw")
+ (version "0.6.7-1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "LambertW" version))
+ (sha256
+ (base32
+ "0cdrq2nrvji8l5blswkffymm7cbjk5jzzx16js2a516cm3gjwxk4"))))
+ (properties `((upstream-name . "LambertW")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-ggplot2
+ r-lamw
+ r-mass
+ r-rcolorbrewer
+ r-rcpp
+ r-reshape2))
+ (native-inputs (list r-knitr))
+ (home-page "https://cran.r-project.org/package=LambertW")
+ (synopsis
+ "Probabilistic models to analyze and Gaussianize heavy-tailed, skewed data")
+ (description
+ "Lambert W x F distributions are a generalized framework to analyze skewed,
+heavy-tailed data. It is based on an input/output system, where the output
+random variable (RV) Y is a non-linearly transformed version of an input RV X
+~ F with similar properties as X, but slightly skewed (heavy-tailed). The
+transformed RV Y has a Lambert W x F distribution. This package contains
+functions to model and analyze skewed, heavy-tailed data the Lambert Way:
+simulate random samples, estimate parameters, compute quantiles, and plot/
+print results nicely. The most useful function is @code{Gaussianize}, which
+works similarly to @code{scale}, but actually makes the data Gaussian. A
+do-it-yourself toolkit allows users to define their own Lambert W x
+@code{MyFavoriteDistribution} and use it in their analysis right away.")
+ (license license:gpl2+)))
+
(define-public r-lamw
(package
(name "r-lamw")