summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNavid Afkhami <navid.afkhami@mdc-berlin.de>2023-02-03 13:18:53 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-02-03 16:05:51 +0100
commit7c798cd9e4052027b524e71a75a5820484e4847c (patch)
tree0d57b46f90d7a1ed431a18ae8045e51af2a6639e
parenta3fcc0a86f07f0295bc81899701972fc8f098bf6 (diff)
downloadguix-patches-7c798cd9e4052027b524e71a75a5820484e4847c.tar
guix-patches-7c798cd9e4052027b524e71a75a5820484e4847c.tar.gz
gnu: Add r-bcellviper.
* gnu/packages/bioconductor.scm (r-bcellviper): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/bioconductor.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 711b988e7f..1a7c53257b 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1248,6 +1248,29 @@ demonstration purposes in the @code{AneuFinder} package.")
from Illumina 450k methylation arrays.")
(license license:artistic2.0)))
+(define-public r-bcellviper
+ (package
+ (name "r-bcellviper")
+ (version "1.34.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "bcellViper" version
+ 'experiment))
+ (sha256
+ (base32
+ "1fpgh70x2r68v0ximgcdphnyzq2hgiwbamyhbac3yka8flhrd1fm"))))
+ (properties `((upstream-name . "bcellViper")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-biobase))
+ (home-page "https://bioconductor.org/packages/bcellViper")
+ (synopsis
+ "Transcriptional interactome and normal human B-cell expression data")
+ (description
+ "This is a tool for human B-cell context-specific transcriptional
+regulatory network. In addition, this package provides a human normal B-cells
+dataset for the examples in package viper.")
+ (license license:gpl2+)))
+
(define-public r-bladderbatch
(package
(name "r-bladderbatch")