summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-03-08 09:38:16 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-03-08 09:38:16 +0200
commit7311a36a544149e5a4478f89df29084a880edd78 (patch)
treee0f925a5d2ead283b2b4addb1d26a68b6ac9d359
parentd4f9c21a84ba4ced10d30c2b3f16faffd7a15f03 (diff)
downloadguix-patches-7311a36a544149e5a4478f89df29084a880edd78.tar
guix-patches-7311a36a544149e5a4478f89df29084a880edd78.tar.gz
Revert "gnu: Add go-github-com-niemeyer-pretty."
This reverts commit 18b0527765301a3015afb9ba1209bd10f56426cb. This package is not actually needed.
-rw-r--r--gnu/packages/golang.scm29
1 files changed, 0 insertions, 29 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 9ee8055eab..7080bb6e24 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5533,35 +5533,6 @@ format in Go.")
(home-page "https://github.com/kr/pretty")
(license license:expat)))
-(define-public go-github-com-niemeyer-pretty
- (package
- (name "go-github-com-niemeyer-pretty")
- (version "0.0.0-20200227124842-a10e7caefd8e")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/niemeyer/pretty")
- (commit (go-version->git-ref version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1jmazh4xzaa3v6g46hz60q2z7nmqs9l9cxdzmmscn3kbcs2znq4v"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; https://github.com/kr/pretty/pull/66
- (substitute* "formatter.go"
- (("string\\(i\\)") "string(rune(i))"))))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/niemeyer/pretty"))
- (propagated-inputs
- (list go-github-com-kr-text))
- (home-page "https://github.com/niemeyer/pretty")
- (synopsis "Pretty printer for Go values")
- (description "This package provides a pretty printer for Go values.")
- (license license:expat)))
-
(define-public go-github-com-kylelemons-godebug
(package
(name "go-github-com-kylelemons-godebug")