summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Tropin <andrew@trop.in>2022-02-07 18:04:26 +0300
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-08 01:07:57 +0100
commit63d5efd92b7e0cb86fb17c48e29f629f5b74e767 (patch)
tree7156b8a3317092c6b924f2b542f0ddd4a4efc0af
parent3610927bc020c65a6daaa40876df0bdd4df814c8 (diff)
downloadguix-patches-63d5efd92b7e0cb86fb17c48e29f629f5b74e767.tar
guix-patches-63d5efd92b7e0cb86fb17c48e29f629f5b74e767.tar.gz
gnu: Add emacs-mct.
* gnu/packages/emacs-xyz.scm (emacs-mct): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 879eaffa23..56af72b2ab 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -994,6 +994,29 @@ process, passing on the arguments as command line arguments.")
"Magit-annex adds a few git-annex operations to the Magit interface.")
(license license:gpl3+)))
+(define-public emacs-mct
+ (package
+ (name "emacs-mct")
+ (version "0.4.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/protesilaos/mct")
+ (commit version)))
+ (sha256
+ (base32 "0sj9hyxpighspwrm2yimqkdxlhw2yiznaj69ysn2sjd6jn2aqpc6"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (home-page "https://protesilaos.com/emacs/mct")
+ (synopsis "Enhancement of the default Emacs minibuffer completion UI")
+ (description "Minibuffer and Completions in Tandem, also known as MCT, or
+mct.el, is an Emacs package that enhances the default minibuffer and
+@samp{*Completions*} buffer so that they work together as part of a unified
+framework. The idea is to make the presentation and overall functionality be
+consistent with other popular, vertically aligned completion UIs while
+leveraging built-in functionality.")
+ (license license:gpl3+)))
+
(define-public emacs-minions
(package
(name "emacs-minions")