summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-01-22 01:00:08 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2023-01-29 01:00:01 +0100
commit5618153e7346e838f20a4e5c042d97eb9ad57314 (patch)
treec675e834a1b48caf31dc1212fef90bad36f0d96d
parent21a4e66f02aacf5ae87105d2157de1b1be29f9b9 (diff)
downloadguix-patches-5618153e7346e838f20a4e5c042d97eb9ad57314.tar
guix-patches-5618153e7346e838f20a4e5c042d97eb9ad57314.tar.gz
gnu: phockup: Properly patch exiftool.
* gnu/packages/image.scm (phockup)[arguments]: Fix 'configure phase to catch all occurrences.
-rw-r--r--gnu/packages/image.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 195d127b31..0b57d88468 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -2428,9 +2428,10 @@ Wacom-style graphics tablets.")
(modify-phases %standard-phases
(add-after 'unpack 'configure
(lambda* (#:key inputs #:allow-other-keys)
- (substitute* (list "src/dependency.py" "src/exif.py")
- (("'exiftool'")
- (string-append "'" (search-input-file inputs "/bin/exiftool") "'")))))
+ (substitute* (list "src/dependency.py"
+ "src/exif.py")
+ (("'exiftool")
+ (string-append "'" (search-input-file inputs "bin/exiftool"))))))
(add-before 'install 'check
(lambda _
(invoke "pytest")))