summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-09-27 18:50:49 +0800
committerEfraim Flashner <efraim@flashner.co.il>2023-09-28 19:39:55 +0300
commit54da3d2c2e8c057d30b827649914308c592cc404 (patch)
treeb7ea1b804a6a61699e9c5b6f1c9233f527779f8c
parentf5040becbf0e702a341f528f350409245ee1b881 (diff)
downloadguix-patches-54da3d2c2e8c057d30b827649914308c592cc404.tar
guix-patches-54da3d2c2e8c057d30b827649914308c592cc404.tar.gz
gnu: Add gcc-13.
* gnu/packages/gcc.scm (gcc-13): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/gcc.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index c3a2d6256c..04926e6385 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -783,6 +783,28 @@ It also includes runtime support libraries for these languages.")
("x86_64" ,@%gcc-12-x86_64-micro-architectures))
,@(package-properties gcc-11)))))
+(define-public gcc-13
+ (package
+ (inherit gcc-11)
+ (version "13.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/gcc/gcc-"
+ version "/gcc-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1nj3qyswcgc650sl3h0480a171ixp33ca13zl90p61m689jffxg2"))
+ (patches (search-patches "gcc-12-strmov-store-file-names.patch"
+ "gcc-5.0-libvtv-runpath.patch"))
+ (modules '((guix build utils)))
+ (snippet gcc-canadian-cross-objdump-snippet)))
+ (properties
+ `((compiler-cpu-architectures
+ ("aarch64" ,@%gcc-13-aarch64-micro-architectures)
+ ("armhf" ,@%gcc-13-armhf-micro-architectures)
+ ("x86_64" ,@%gcc-13-x86_64-micro-architectures))
+ ,@(package-properties gcc-11)))))
+
;; Note: When changing the default gcc version, update
;; the gcc-toolchain-* definitions.