summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-27 11:35:30 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-27 11:48:16 +0100
commit54b0b96c5b297e39580bc0367d5908833fe69ca7 (patch)
treead6a9a8721d6bde47878da7ebc31fe1a8ca05bf7
parent7fa47c07168fac489224b0b5e56d43b8e7cf8632 (diff)
downloadguix-patches-54b0b96c5b297e39580bc0367d5908833fe69ca7.tar
guix-patches-54b0b96c5b297e39580bc0367d5908833fe69ca7.tar.gz
gnu: libksysguard: Remove reference to '%outputs'.
* gnu/packages/kde-plasma.scm (libksysguard)[arguments]: Remove reference to '%outputs' and use gexps.
-rw-r--r--gnu/packages/kde-plasma.scm32
1 files changed, 17 insertions, 15 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 96e7ec6907..8496208816 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -25,6 +25,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix gexp)
#:use-module (guix build-system cmake)
#:use-module (guix build-system qt)
#:use-module (gnu packages compression)
@@ -269,21 +270,22 @@ basic needs and easy to configure for those who want special setups.")
("zlib" ,zlib)))
(build-system qt-build-system)
(arguments
- `(#:configure-flags
- `(,(string-append "-DKDE_INSTALL_DATADIR="
- (assoc-ref %outputs "out") "/share"))
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'patch-cmakelists
- (lambda _
- ;; TODO: Verify: This should no longer be necessary, since
- ;; KF5AuthConfig.cmake.in contains this already.
- (substitute* "processcore/CMakeLists.txt"
- (("KAUTH_HELPER_INSTALL_DIR") "KDE_INSTALL_LIBEXECDIR"))))
- (replace 'check
- (lambda _
- ;; TODO: Fix this failing test-case
- (invoke "ctest" "-E" "processtest"))))))
+ (list #:configure-flags
+ #~`(,(string-append "-DKDE_INSTALL_DATADIR="
+ #$output "/share"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'configure 'patch-cmakelists
+ (lambda _
+ ;; TODO: Verify: This should no longer be necessary, since
+ ;; KF5AuthConfig.cmake.in contains this already.
+ (substitute* "processcore/CMakeLists.txt"
+ (("KAUTH_HELPER_INSTALL_DIR")
+ "KDE_INSTALL_LIBEXECDIR"))))
+ (replace 'check
+ (lambda _
+ ;; TODO: Fix this failing test-case
+ (invoke "ctest" "-E" "processtest"))))))
(home-page "https://userbase.kde.org/KSysGuard")
(synopsis "Network enabled task and system monitoring")
(description "KSysGuard can obtain information on system load and