summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-10-14 14:39:23 +0200
committerLudovic Courtès <ludo@gnu.org>2015-10-14 14:41:26 +0200
commit53b5856ac1b19a6e7c74f781b1f14bf37965a8a4 (patch)
tree289512946f2ef5f3ba06d1826a01f1b3aa036ebe
parentbbe04ae102211d6486691652a4892744ee7f9a85 (diff)
downloadguix-patches-53b5856ac1b19a6e7c74f781b1f14bf37965a8a4.tar
guix-patches-53b5856ac1b19a6e7c74f781b1f14bf37965a8a4.tar.gz
gnu: glib: Update to 2.46.0.
* gnu/packages/glib.scm (glib): Update to 2.46.0. * gnu/packages/patches/glib-tests-desktop.patch: Add hunk to disable 'gdbus-unix-addresses' test.
-rw-r--r--gnu/packages/glib.scm4
-rw-r--r--gnu/packages/patches/glib-tests-desktop.patch18
2 files changed, 16 insertions, 6 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 9137db3949..c223b56096 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -124,7 +124,7 @@ shared NFS home directories.")
(define glib
(package
(name "glib")
- (version "2.44.1")
+ (version "2.46.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/"
@@ -132,7 +132,7 @@ shared NFS home directories.")
name "-" version ".tar.xz"))
(sha256
(base32
- "01yabrfp64i11mrks3p1gcks99lw0zm7f5vhkc53sl4amyndw4c8"))
+ "1d5cpb2zp5js98jjnbfn1fb96kj1j3q3fz16gkqq0zdfd4sfikmi"))
(patches (list (search-patch "glib-tests-homedir.patch")
(search-patch "glib-tests-desktop.patch")
(search-patch "glib-tests-prlimit.patch")
diff --git a/gnu/packages/patches/glib-tests-desktop.patch b/gnu/packages/patches/glib-tests-desktop.patch
index 61f48607f7..642234ebbc 100644
--- a/gnu/packages/patches/glib-tests-desktop.patch
+++ b/gnu/packages/patches/glib-tests-desktop.patch
@@ -56,11 +56,12 @@ database, the `update-desktop-database' program, which we don't provide.
-----------------------------
The hunk below removes tests that depend on `gdbus-testserver.py',
-because that script depends on python-gobject.
+because that script depends on python-gobject. The second hunk
+disables a test that expects /etc/machine-id in the build environment.
---- glib-2.39.1/gio/tests/Makefile.in 2014-01-20 00:18:16.000000000 +0100
-+++ glib-2.39.1/gio/tests/Makefile.in 2014-01-20 00:18:47.000000000 +0100
-@@ -171,20 +171,13 @@ check_PROGRAMS = $(am__EXEEXT_14)
+--- glib-2.46.0/gio/tests/Makefile.in 2015-10-14 14:11:00.928809504 +0200
++++ glib-2.46.0/gio/tests/Makefile.in 2015-10-14 14:12:13.157291092 +0200
+@@ -186,20 +186,13 @@ check_PROGRAMS = $(am__EXEEXT_16)
@HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@ gdbus-auth \
@HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@ gdbus-bz627724 \
@HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@ gdbus-close-pending \
@@ -79,7 +80,16 @@ because that script depends on python-gobject.
@HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@ gdbus-test-codegen-old \
-@HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@ gdbus-threading \
@HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@ gmenumodel \
+ @HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@ gnotification \
@HAVE_DBUS_DAEMON_TRUE@@OS_UNIX_TRUE@ $(NULL)
+@@ -321,8 +314,7 @@ libresourceplugin_la_LINK = $(LIBTOOL) $
+ am__EXEEXT_1 =
+ @OS_UNIX_TRUE@am__EXEEXT_2 = contenttype$(EXEEXT) file$(EXEEXT) \
+ @OS_UNIX_TRUE@ gdbus-peer-object-manager$(EXEEXT) \
+-@OS_UNIX_TRUE@ gdbus-unix-addresses$(EXEEXT) \
+ @OS_UNIX_TRUE@ live-g-file$(EXEEXT) socket-address$(EXEEXT) \
+ @OS_UNIX_TRUE@ stream-rw_all$(EXEEXT) unix-fd$(EXEEXT) \
+ @OS_UNIX_TRUE@ unix-streams$(EXEEXT) $(am__EXEEXT_1) \
The test below depends on the availability /etc/passwd to dbus-daemon.