summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-05-22 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-22 02:00:09 +0200
commit52431e42ef92beb89ef31e3fd3ec178254b8d630 (patch)
treea290c25b8c12d7855404c72495a98dbcf6db8ca6
parente490aacde1f8d9bb30cb7bdd4ea72810ca1a3837 (diff)
downloadguix-patches-52431e42ef92beb89ef31e3fd3ec178254b8d630.tar
guix-patches-52431e42ef92beb89ef31e3fd3ec178254b8d630.tar.gz
gnu: lynis: Work.
Work around <https://issues.guix.gnu.org/55287>. * gnu/packages/admin.scm (lynis)[arguments]: Add a custom 'unpack phase that doesn't MAKE-FILE-WRITABLE.
-rw-r--r--gnu/packages/admin.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 38239e1f05..d22753c64f 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -4399,6 +4399,13 @@ Logitech Unifying Receiver.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (replace 'unpack
+ ;; XXX Remove after fixing <https://issues.guix.gnu.org/55287>.
+ (lambda* (#:key source #:allow-other-keys)
+ (mkdir "source")
+ (chdir "source")
+ (copy-recursively source "."
+ #:keep-mtime? #t)))
(replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
(substitute* "lynis"