summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-06-22 15:34:32 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-06-23 09:42:41 +0300
commit4f6ed3d2f8531ce1b75dc79365ce67587d8cb7e1 (patch)
tree9a96575dcca7895d91cbbe8a6501e7999f1634d8
parent4a1550516ab7d90864f93f2e4ad2aefb5fc18d11 (diff)
downloadguix-patches-4f6ed3d2f8531ce1b75dc79365ce67587d8cb7e1.tar
guix-patches-4f6ed3d2f8531ce1b75dc79365ce67587d8cb7e1.tar.gz
gnu: ldc-bootstrap-0.17: Add support for aarch64-linux.
* gnu/packages/dlang.scm (ldc-bootstrap-0.17)[supported-systems]: Add aarch64-linux. [arguments]: When building targeting aarch64-linux build for armhf-linux.
-rw-r--r--gnu/packages/dlang.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/dlang.scm b/gnu/packages/dlang.scm
index 403fcbbd6b..75e2155c83 100644
--- a/gnu/packages/dlang.scm
+++ b/gnu/packages/dlang.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
-;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -103,13 +103,17 @@ and freshness without requiring additional information from the user.")
(sha256
(base32 "1q6hm4fkrcwys83x0p4kfg9xrc1b9g2qicqif2zy5z4nsfsb5vgs"))))
(build-system cmake-build-system)
- (supported-systems '("x86_64-linux" "i686-linux" "armhf-linux"))
+ (supported-systems '("x86_64-linux" "i686-linux"
+ "armhf-linux" "aarch64-linux"))
(properties
;; Some of the tests take a very long time on ARMv7. See
;; <https://lists.gnu.org/archive/html/guix-devel/2018-02/msg00312.html>.
`((max-silent-time . ,(* 3600 3))))
(arguments
`(#:tests? #f ;requires obsolete python-lit test dependency
+ ,@(if (target-aarch64?)
+ '(#:system "armhf-linux")
+ '())
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'unpack-submodule-sources