summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2022-05-30 09:03:02 +0200
committerRoel Janssen <roel@gnu.org>2022-05-30 09:03:02 +0200
commit48efbde7a944acfe4fc944bf27bfa9ff82592024 (patch)
treedf1cbeed12996e165ce44f78e119672a3959895d
parent7f63a6aefc8ae146150be2fb6897b1b2c9fd1907 (diff)
downloadguix-patches-48efbde7a944acfe4fc944bf27bfa9ff82592024.tar
guix-patches-48efbde7a944acfe4fc944bf27bfa9ff82592024.tar.gz
gnu: virtuoso-ose: Update to 7.2.7.
* gnu/packages/databases.scm (virtuoso-ose): Update to 7.2.7; Run autogen after applying the patch below. * gnu/packages/patches/virtuoso-ose-remove-pre-built-jar-files.patch: New file.
-rw-r--r--gnu/packages/databases.scm26
-rw-r--r--gnu/packages/patches/virtuoso-ose-remove-pre-built-jar-files.patch117
2 files changed, 141 insertions, 2 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 2d72c78233..a161e29907 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -100,6 +100,7 @@
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages golang)
+ #:use-module (gnu packages gperf)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
#:use-module (gnu packages icu4c)
@@ -3229,14 +3230,30 @@ Memory-Mapped Database} (LMDB), a high-performance key-value store.")
(define-public virtuoso-ose
(package
(name "virtuoso-ose")
- (version "7.2.6")
+ (version "7.2.7")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/virtuoso/virtuoso/" version "/"
"virtuoso-opensource-" version ".tar.gz"))
(sha256
- (base32 "0ly7s7a3w2a2zhhi9rq9k2qlnzapqbbc1rcdqb3zqqpgg81krz9q"))))
+ (base32 "1853ln0smiilf3pni70gq6nmi9ps039cy44g6b5i9d2z1n9hnj02"))
+ (patches (search-patches "virtuoso-ose-remove-pre-built-jar-files.patch"))
+ (modules '((guix build utils)))
+ ;; This snippet removes pre-built Java archives.
+ (snippet
+ '(for-each delete-file-recursively
+ (list "binsrc/hibernate"
+ "binsrc/jena"
+ "binsrc/jena2"
+ "binsrc/jena3"
+ "binsrc/jena4"
+ "binsrc/rdf4j"
+ "binsrc/sesame"
+ "binsrc/sesame2"
+ "binsrc/sesame3"
+ "binsrc/sesame4"
+ "libsrc/JDBCDriverType4")))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; Tests require a network connection.
@@ -3247,6 +3264,9 @@ Memory-Mapped Database} (LMDB), a high-performance key-value store.")
"--enable-static=no")
#:phases
(modify-phases %standard-phases
+ (replace 'bootstrap
+ (lambda _
+ (invoke "sh" "autogen.sh")))
;; Even with "--enable-static=no", "libvirtuoso-t.a" is left in
;; the build output. The following phase removes it.
(add-after 'install 'remove-static-libs
@@ -3256,6 +3276,8 @@ Memory-Mapped Database} (LMDB), a high-performance key-value store.")
(delete-file (string-append lib "/" file)))
'("libvirtuoso-t.a"
"libvirtuoso-t.la"))))))))
+ (native-inputs
+ (list autoconf automake bison flex gperf libtool))
(inputs
(list openssl net-tools readline zlib))
(home-page "http://vos.openlinksw.com/owiki/wiki/VOS/")
diff --git a/gnu/packages/patches/virtuoso-ose-remove-pre-built-jar-files.patch b/gnu/packages/patches/virtuoso-ose-remove-pre-built-jar-files.patch
new file mode 100644
index 0000000000..17413c71ae
--- /dev/null
+++ b/gnu/packages/patches/virtuoso-ose-remove-pre-built-jar-files.patch
@@ -0,0 +1,117 @@
+This patch disables build targets that contain pre-built Java archives that
+would be copied to the build's output.
+
+Patch by Roel Janssen <roel@gnu.org>
+*** a-virtuoso-opensource-7.2.7/binsrc/Makefile.am 1970-01-01 01:00:01.000000000 +0100
+--- b-virtuoso-opensource-7.2.7/binsrc/Makefile.am 2022-05-27 12:20:52.909135774 +0200
+***************
+*** 19,25 ****
+ #
+ #
+
+! SUBDIRS = dav mono virtuoso tests rdf_mappers driver maildrop sqldoc hosting bpel fct tutorial conductor samples vsp ws sync vspx vad cached_resources virtodbc virtoledb virtuoso_sink xddl VirtuosoClient.Net oat isparql jena jena2 jena3 jena4 sesame sesame2 sesame3 sesame4 redland hibernate dbpedia rdb2rdf rdf4j
+
+
+ # ----------------------------------------------------------------------
+--- 19,25 ----
+ #
+ #
+
+! SUBDIRS = dav mono virtuoso tests rdf_mappers driver maildrop sqldoc hosting bpel fct tutorial conductor samples vsp ws sync vspx vad cached_resources virtodbc virtoledb virtuoso_sink xddl VirtuosoClient.Net oat isparql redland dbpedia rdb2rdf
+
+
+ # ----------------------------------------------------------------------
+*** a-virtuoso-opensource-7.2.7/configure.ac 1970-01-01 01:00:01.000000000 +0100
+--- b-virtuoso-opensource-7.2.7/configure.ac 2022-05-27 12:27:51.879208018 +0200
+***************
+*** 57,64 ****
+ dnl AM_INIT_AUTOMAKE([1.8])
+ dnl AM_INIT_AUTOMAKE([1.9 tar-ustar])
+ dnl
+! AM_INIT_AUTOMAKE([1.9 tar-ustar])
+!
+ AM_MAINTAINER_MODE
+
+
+--- 57,63 ----
+ dnl AM_INIT_AUTOMAKE([1.8])
+ dnl AM_INIT_AUTOMAKE([1.9 tar-ustar])
+ dnl
+! AM_INIT_AUTOMAKE([1.9 tar-ustar subdir-objects])
+ AM_MAINTAINER_MODE
+
+
+***************
+*** 3157,3163 ****
+ binsrc/dbpedia/Makefile
+ binsrc/driver/Makefile
+ binsrc/fct/Makefile
+- binsrc/hibernate/Makefile
+ binsrc/hosting/Makefile
+ binsrc/hosting/mono/Makefile
+ binsrc/hosting/mono/tests/Makefile
+--- 3156,3161 ----
+***************
+*** 3169,3184 ****
+ binsrc/hosting/ruby/Makefile
+ binsrc/hosting/shapefileio/Makefile
+ binsrc/isparql/Makefile
+- binsrc/jena/Makefile
+- binsrc/jena2/Makefile
+- binsrc/jena3/Makefile
+- binsrc/jena4/Makefile
+ binsrc/maildrop/Makefile
+ binsrc/mono/Makefile
+ binsrc/oat/Makefile
+ binsrc/rdf_mappers/Makefile
+ binsrc/rdb2rdf/Makefile
+- binsrc/rdf4j/Makefile
+ binsrc/redland/Makefile
+ binsrc/samples/demo/Makefile
+ binsrc/samples/hslookup/Makefile
+--- 3167,3177 ----
+***************
+*** 3191,3200 ****
+ binsrc/samples/webapp/Makefile
+ binsrc/samples/xpath/Makefile
+ binsrc/samples/xquery/Makefile
+- binsrc/sesame/Makefile
+- binsrc/sesame2/Makefile
+- binsrc/sesame3/Makefile
+- binsrc/sesame4/Makefile
+ binsrc/sqldoc/Makefile
+ binsrc/sync/Makefile
+ binsrc/tests/biftest/Makefile
+--- 3184,3189 ----
+***************
+*** 3236,3245 ****
+ docsrc/stylesheets/Makefile
+ docsrc/xmlsource/Makefile
+ libsrc/Dk/Makefile
+- libsrc/JDBCDriverType4/Makefile
+- libsrc/JDBCDriverType4/testsuite_4.0/Makefile
+- libsrc/JDBCDriverType4/virtuoso/jdbc/Makefile
+- libsrc/JDBCDriverType4/virtuoso/Makefile
+ libsrc/langfunc/Makefile
+ libsrc/odbcsdk/Makefile
+ libsrc/plugin/Makefile
+--- 3225,3230 ----
+*** a-virtuoso-opensource-7.2.7/libsrc/Makefile.am 1970-01-01 01:00:01.000000000 +0100
+--- b-virtuoso-opensource-7.2.7/libsrc/Makefile.am 2022-05-27 12:30:12.658593011 +0200
+***************
+*** 19,25 ****
+ #
+ #
+
+! SUBDIRS = util zlib odbcsdk Dk Thread langfunc Wi plugin Tidy Xml.new JDBCDriverType4
+
+ noinst_HEADERS = Dk.h libutil.h
+
+--- 19,25 ----
+ #
+ #
+
+! SUBDIRS = util zlib odbcsdk Dk Thread langfunc Wi plugin Tidy Xml.new
+
+ noinst_HEADERS = Dk.h libutil.h
+