summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2021-12-17 04:35:23 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2021-12-17 04:43:08 +0100
commit47843a14a4fefdd1bb1ae3578d1466c4314ef152 (patch)
tree7b62cbb8e5dcc5e09f19b1f259b7017ae2a56f92
parenteb4ce2de6993bace0af3e8a52137cf17f56c034e (diff)
downloadguix-patches-47843a14a4fefdd1bb1ae3578d1466c4314ef152.tar
guix-patches-47843a14a4fefdd1bb1ae3578d1466c4314ef152.tar.gz
gnu: telepathy-glib: Update to 0.24.2.
* gnu/packages/glib.scm (telepathy-glib): Update to 0.24.2. [source]: Drop upstreamed patches. * gnu/packages/patches/telepathy-glib-channel-memory-leak.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/glib.scm16
-rw-r--r--gnu/packages/patches/telepathy-glib-channel-memory-leak.patch19
3 files changed, 2 insertions, 34 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 6022c0fb90..8c06ce7f23 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1820,7 +1820,6 @@ dist_patch_DATA = \
%D%/packages/patches/teensy-loader-cli-help.patch \
%D%/packages/patches/texinfo-5-perl-compat.patch \
%D%/packages/patches/telegram-purple-adjust-test.patch \
- %D%/packages/patches/telepathy-glib-channel-memory-leak.patch \
%D%/packages/patches/texi2html-document-encoding.patch \
%D%/packages/patches/texi2html-i18n.patch \
%D%/packages/patches/thefuck-test-environ.patch \
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index a18bffac55..1bd1d6c138 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -995,7 +995,7 @@ libraries. Examples include gtk+, webkit, libsoup and many more.")
(define telepathy-glib
(package
(name "telepathy-glib")
- (version "0.24.1")
+ (version "0.24.2")
(source
(origin
(method url-fetch)
@@ -1005,19 +1005,7 @@ libraries. Examples include gtk+, webkit, libsoup and many more.")
"telepathy-glib-" version ".tar.gz"))
(sha256
(base32
- "1symyzbjmxvksn2ifdkk50lafjm2llf2sbmky062gq2pz3cg23cy"))
- (patches
- (list
- (search-patch "telepathy-glib-channel-memory-leak.patch")
- ;; Don't use the same test name for multiple tests.
- ;; <https://bugs.freedesktop.org/show_bug.cgi?id=92245>
- (origin
- (method url-fetch)
- (uri "https://bugs.freedesktop.org/attachment.cgi?id=118608")
- (file-name (string-append "telepathy-glib-duplicate-tests.patch"))
- (sha256
- (base32
- "0z261fwrszxb28ccg3hsg9rizig4s84zvwmx6y31a4pyv7bvs5w3")))))))
+ "1w3kja8j3gz2apal79bi3hq44xk5g78aphrqbw983l6df7bp98xh"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--enable-vala-bindings")
diff --git a/gnu/packages/patches/telepathy-glib-channel-memory-leak.patch b/gnu/packages/patches/telepathy-glib-channel-memory-leak.patch
deleted file mode 100644
index fe07548ec0..0000000000
--- a/gnu/packages/patches/telepathy-glib-channel-memory-leak.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Prevent a memory leak in call-channel, which otherwise would cause a
-test failure in file-transfer-channel.c.
-
-Taken from upstream:
-https://gitlab.freedesktop.org/telepathy/telepathy-glib/commit/2e8b2cc0db09b781d99e3755bb6d01548037fe7b
-
-diff --git a/telepathy-glib/call-channel.c b/telepathy-glib/call-channel.c
-index 8ed76323be32f83c5f4d6045a50bc1698d8093fd..2a1fa203d4be9f0c8b99344225f4ba9900666ffc 100644
---- a/telepathy-glib/call-channel.c
-+++ b/telepathy-glib/call-channel.c
-@@ -525,6 +525,8 @@ update_call_members (TpCallChannel *self,
-
- _tp_channel_contacts_queue_prepare_async ((TpChannel *) self,
- contacts, update_call_members_prepared_cb, data);
-+
-+ g_ptr_array_unref (contacts);
- }
-
- static void