summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author( <paren@disroot.org>2022-10-21 22:11:33 +0100
committerRaghav Gururajan <rg@raghavgururajan.name>2022-11-27 10:46:08 -0500
commit46fbb3e498c804636d9092c389f8c75eff20e120 (patch)
treec005aee48683bd930da14f72d65c48c62541b29b
parent1e2cefd0e8dcf8c71bd690d03535c217211be252 (diff)
downloadguix-patches-46fbb3e498c804636d9092c389f8c75eff20e120.tar
guix-patches-46fbb3e498c804636d9092c389f8c75eff20e120.tar.gz
gnu: Add go-github-com-syndtr-goleveldb-leveldb.
* gnu/packages/golang.scm (go-github-com-syndtr-goleveldb-leveldb): New variable. Signed-off-by: Raghav Gururajan <rg@raghavgururajan.name>
-rw-r--r--gnu/packages/golang.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 31958aec7b..d41e705124 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6093,6 +6093,33 @@ without requiring a real database connection.")
golang's database/sql package.")
(license license:mpl2.0)))
+(define-public go-github-com-syndtr-goleveldb-leveldb
+ (package
+ (name "go-github-com-syndtr-goleveldb-leveldb")
+ (version "1.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/syndtr/goleveldb")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "042k0gbzs5waqpxmd7nv5h93mlva861s66c3s9gfg1fym5dx4vmd"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/syndtr/goleveldb/leveldb"
+ #:unpack-path "github.com/syndtr/goleveldb"))
+ (propagated-inputs (list go-github-com-onsi-gomega
+ go-github-com-onsi-ginkgo
+ go-github-com-golang-snappy))
+ (home-page "https://github.com/syndtr/goleveldb")
+ (synopsis "LevelDB implementation in Go")
+ (description
+ "This package provides a Go implementation of the LevelDB key/value
+storage system.")
+ (license license:bsd-2)))
+
(define-public go-github-com-lucasb-eyer-go-colorful
(package
(name "go-github-com-lucasb-eyer-go-colorful")