summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-15 22:39:39 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-15 22:39:39 +0100
commit467fb8abc515993ed39b1cfbbfcfc56ca47cfee8 (patch)
treefbd5ac68e63df2292cae57e537257825a06bd15a
parentf542ef076a2238c36d5e9ed65836558375d3dd27 (diff)
downloadguix-patches-467fb8abc515993ed39b1cfbbfcfc56ca47cfee8.tar
guix-patches-467fb8abc515993ed39b1cfbbfcfc56ca47cfee8.tar.gz
gnu: emacs-embark: Update to 0.15.
* gnu/packages/emacs-xyz.scm (emacs-embark): Update to 0.15.
-rw-r--r--gnu/packages/emacs-xyz.scm43
1 files changed, 20 insertions, 23 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c5cb07e16e..3562547feb 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8115,28 +8115,25 @@ them easier to distinguish from other, less important buffers.")
(license license:expat)))
(define-public emacs-embark
- ;; XXX: Upstream did not tag last release. Commit hash below matches
- ;; version bump.
- (let ((commit "5ebe2dfd91868ec525ea34ffd45941c5e9ce5358"))
- (package
- (name "emacs-embark")
- (version "0.14")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/oantolin/embark")
- (commit commit)))
- (sha256
- (base32 "07siy3kxx06nklsw0aysfy0ijssqbql4v43vs60kwvzs875w4d2s"))
- (file-name (git-file-name name version))))
- (build-system emacs-build-system)
- (propagated-inputs
- (list emacs-avy emacs-consult))
- (home-page "https://github.com/oantolin/embark")
- (synopsis "Emacs mini-buffer actions rooted in keymaps")
- (description
- "This package provides a sort of right-click contextual menu for Emacs
+ (package
+ (name "emacs-embark")
+ (version "0.15")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/oantolin/embark")
+ (commit version)))
+ (sha256
+ (base32 "08wj0p3plvblbmfmn4vsanhldr2csrnm1lhk3g1nic5v26yi5l64"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ (list emacs-avy emacs-consult))
+ (home-page "https://github.com/oantolin/embark")
+ (synopsis "Emacs mini-buffer actions rooted in keymaps")
+ (description
+ "This package provides a sort of right-click contextual menu for Emacs
offering you relevant @emph{actions} to use on a @emph{target} determined by
the context.
@@ -8150,7 +8147,7 @@ get offered actions like deleting, copying, renaming, visiting in another
window, running a shell command on the file, etc. For buffers the actions
include switching to or killing the buffer. For package names the actions
include installing, removing or visiting the homepage.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-prescient
(package