summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-08 22:35:03 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-08 22:35:03 +0100
commit3b8825421b4cfb44fffd4e3bae312d0b2b8aac62 (patch)
tree630c7b12071a89d2e1eb4366789dc9b78e7809d1
parent77c8382bb67bd334b3907c246ee064cda4b771ce (diff)
downloadguix-patches-3b8825421b4cfb44fffd4e3bae312d0b2b8aac62.tar
guix-patches-3b8825421b4cfb44fffd4e3bae312d0b2b8aac62.tar.gz
gnu: geeqie: Fix X11 error at startup.
Fixes <https://issues.guix.gnu.org/52089>. Reported by Maxim Cournoyer <maxim.cournoyer@gmail.com>. Patch provided by John Kehayias <john.kehayias@protonmail.com>. * gnu/packages/patches/geeqie-clutter.patch: New file. * gnu/packages/image-viewers.scm (geeqie)[sources]: Use it. * gnu/local.mk (dist_patch_DATA): Add it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/image-viewers.scm3
-rw-r--r--gnu/packages/patches/geeqie-clutter.patch35
3 files changed, 38 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 5c19919f2e..621daced2b 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1121,6 +1121,7 @@ dist_patch_DATA = \
%D%/packages/patches/gdm-remove-hardcoded-xwayland-path.patch \
%D%/packages/patches/gdm-wayland-session-wrapper-from-env.patch \
%D%/packages/patches/gdm-pass-gdk-pixbuf-loader-env.patch \
+ %D%/packages/patches/geeqie-clutter.patch \
%D%/packages/patches/genimage-mke2fs-test.patch \
%D%/packages/patches/geoclue-config.patch \
%D%/packages/patches/ghc-8.0-fall-back-to-madv_dontneed.patch \
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index d2307a33e8..ff6af70a2c 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -314,7 +314,8 @@ actions.")
(sha256
(base32
"1i9yd8lddp6b9s9vjjjzbpqj4bvwidxc6kiba6vdrk7dda5akyky"))
- (file-name (git-file-name name version))))
+ (file-name (git-file-name name version))
+ (patches (search-patches "geeqie-clutter.patch"))))
(build-system gnu-build-system)
(arguments
;; Enable support for a "map" pane using GPS data.
diff --git a/gnu/packages/patches/geeqie-clutter.patch b/gnu/packages/patches/geeqie-clutter.patch
new file mode 100644
index 0000000000..ab7cc957d8
--- /dev/null
+++ b/gnu/packages/patches/geeqie-clutter.patch
@@ -0,0 +1,35 @@
+From c99084ac5fc2fb854ff8e8abd4bd3298fb08fb43 Mon Sep 17 00:00:00 2001
+From: Colin Clark <colin.clark@cclark.uk>
+Date: Sat, 9 Jan 2021 11:35:41 +0000
+Subject: [PATCH] Fix #829: segfault with clutter-gtk
+
+https://github.com/BestImageViewer/geeqie/issues/829
+
+This fix might cause other problems which might be cured by calling:
+LIBGL_ALWAYS_INDIRECT=1 geeqie
+
+or, worst case:
+geeqie --disable-clutter
+---
+ src/main.c | 5 -----
+ 1 file changed, 5 deletions(-)
+
+diff --git a/src/main.c b/src/main.c
+index f497240d..4af654fe 100644
+--- a/src/main.c
++++ b/src/main.c
+@@ -904,11 +904,6 @@ gint main(gint argc, gchar *argv[])
+ #ifdef HAVE_GTHREAD
+ #if !GLIB_CHECK_VERSION(2,32,0)
+ g_thread_init(NULL);
+-#endif
+-#ifdef HAVE_CLUTTER
+-/* FIXME: see below */
+- putenv("LIBGL_ALWAYS_INDIRECT=1");
+- XInitThreads();
+ #endif
+ gdk_threads_init();
+ gdk_threads_enter();
+--
+2.34.0
+