summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikolay Korotkiy <sikmir@disroot.org>2023-01-07 03:22:45 +0400
committer宋文武 <iyzsong@member.fsf.org>2023-01-28 14:18:03 +0800
commit3a5937d240a03dd8aa7e550e45c4ee320d093ba9 (patch)
tree9d592c412635479f85157a99238f8946b54bf020
parent2f2846404ddf50ad2c751e855b5b3dda32ecf65c (diff)
downloadguix-patches-3a5937d240a03dd8aa7e550e45c4ee320d093ba9.tar
guix-patches-3a5937d240a03dd8aa7e550e45c4ee320d093ba9.tar.gz
gnu: tegola: Update to 0.16.0.
* gnu/packages/geo.scm (tegola): Update to 0.16.0. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/geo.scm15
1 files changed, 4 insertions, 11 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 13acad6322..432903acc9 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1281,7 +1281,7 @@ extension.")
(define-public tegola
(package
(name "tegola")
- (version "0.7.0")
+ (version "0.16.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1290,20 +1290,13 @@ extension.")
(file-name (git-file-name name version))
(sha256
(base32
- "0agqj1b7l41m0imvxjriw44jcpa99mhq1z1vbsfzjhcr94zhwmfr"))))
+ "1mjfn0izf1lj402845mx0cv9fald8s5443q35y16d9crqf3i6mav"))))
(build-system go-build-system)
(arguments
`(#:import-path "github.com/go-spatial/tegola/cmd/tegola"
#:unpack-path "github.com/go-spatial/tegola"
- #:phases
- (modify-phases %standard-phases
- (add-before 'build 'set-version
- (lambda _
- (with-directory-excursion "src/github.com/go-spatial/tegola"
- (substitute* '("cmd/tegola/cmd/root.go"
- "cmd/tegola_lambda/main.go")
- (("version not set") ,version)))
- #t)))))
+ #:build-flags '(,(string-append "-ldflags=-X github.com/go-spatial/tegola/internal/build.Version=" version))
+ #:install-source? #f))
(home-page "https://tegola.io")
(synopsis "Vector tile server for maps")
(description "Tegola is a free vector tile server written in Go. Tegola