summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEvgeny Pisemsky <evgeny@pisemsky.com>2022-02-01 16:45:45 +0300
committer宋文武 <iyzsong@member.fsf.org>2022-02-02 11:51:05 +0800
commit385427256a77ce609d76c94d900966dbbd3b53ea (patch)
tree46e293ba797b676ce69d8161784a675e7b44768d
parentfff4daa5c2bfbf42c7ad2519f500bd254ce880a8 (diff)
downloadguix-patches-385427256a77ce609d76c94d900966dbbd3b53ea.tar
guix-patches-385427256a77ce609d76c94d900966dbbd3b53ea.tar.gz
gnu: Add wireviz.
* gnu/packages/engineering.scm (wireviz): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
-rw-r--r--gnu/packages/engineering.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 04f5ba88b9..8464397958 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -27,6 +27,7 @@
;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
+;;; Copyright © 2022 Evgeny Pisemsky <evgeny@pisemsky.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3272,3 +3273,24 @@ G-code instructions for FFF printers or PNG layers for mSLA 3D printers.")
;; Mark as tunable to take advantage of SIMD code in Eigen and in libigl.
(properties '((tunable? . #t)))))
+
+(define-public wireviz
+ (package
+ (name "wireviz")
+ (version "0.3.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "wireviz" version))
+ (sha256
+ (base32
+ "1dgnlxxlna2m1fh0ybivw0psym0sa5cqsl72mjl79bwfspnif61h"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-graphviz python-pillow python-pyyaml))
+ (home-page "https://github.com/formatc1702/WireViz")
+ (synopsis "Easily document cables and wiring harnesses")
+ (description
+ "WireViz is a tool for easily documenting cables, wiring harnesses and
+connector pinouts. It takes plain text, YAML-formatted files as input and
+produces beautiful graphical output thanks to GraphViz. It handles automatic
+BOM creation and has a lot of extra features.")
+ (license license:gpl3)))