summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikita Karetnikov <nikita@karetnikov.org>2012-11-22 00:50:28 +0000
committerLudovic Courtès <ludo@gnu.org>2012-11-22 22:37:20 +0100
commit36d4d49e694f87aa950101724800171baa74f8b3 (patch)
tree98bdbecf1b5bed9840249aedf1536e456a10e9a6
parent80ffc7082c52fb5cbf89ea7cf8d5da3b6ff5fd0b (diff)
downloadguix-patches-36d4d49e694f87aa950101724800171baa74f8b3.tar
guix-patches-36d4d49e694f87aa950101724800171baa74f8b3.tar.gz
distro: Move (distro packages libtool) to (distro packages autotools).
* distro/packages/autotools.scm (libtool): Add it. * distro/packages/libtool.scm: Remove it. * distro/packages/guile.scm (distro packages guile): Adjust accordingly. * Makefile.am (MODULES): Adjust accordingly.
-rw-r--r--Makefile.am1
-rw-r--r--distro/packages/autotools.scm32
-rw-r--r--distro/packages/guile.scm2
-rw-r--r--distro/packages/libtool.scm56
4 files changed, 33 insertions, 58 deletions
diff --git a/Makefile.am b/Makefile.am
index 7fe7853226..dbc507170c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -60,7 +60,6 @@ MODULES = \
distro/packages/ld-wrapper.scm \
distro/packages/libffi.scm \
distro/packages/libsigsegv.scm \
- distro/packages/libtool.scm \
distro/packages/libunistring.scm \
distro/packages/lout.scm \
distro/packages/m4.scm \
diff --git a/distro/packages/autotools.scm b/distro/packages/autotools.scm
index 55b052bbae..61e7029cde 100644
--- a/distro/packages/autotools.scm
+++ b/distro/packages/autotools.scm
@@ -1,5 +1,6 @@
;;; Guix --- Nix package management from Guile. -*- coding: utf-8 -*-
;;; Copyright (C) 2012 Nikita Karetnikov <nikita@karetnikov.org>
+;;; Copyright (C) 2012 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of Guix.
;;;
@@ -17,6 +18,7 @@
;;; along with Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (distro packages autotools)
+ #:use-module (distro)
#:use-module (distro packages perl)
#:use-module (distro packages m4)
#:use-module (guix packages)
@@ -81,3 +83,33 @@ can use, in the form of M4 macro calls.")
`Makefile.in' files compliant with the GNU Coding
Standards. Automake requires the use of Autoconf.")
(license "GPLv2+"))) ; some files are under GPLv3+
+
+(define-public libtool
+ (package
+ (name "libtool")
+ (version "2.4.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/libtool/libtool-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0649qfpzkswgcj9vqkkr9rn4nlcx80faxpyqscy2k1x9c94f93dk"))))
+ (build-system gnu-build-system)
+ (native-inputs `(("m4" ,m4)
+ ("perl" ,perl)))
+ (arguments
+ ;; TODO: Use `TESTSUITEFLAGS=-jN' for tests.
+ `(#:patches (list (assoc-ref %build-inputs "patch/skip-tests"))))
+ (inputs `(("patch/skip-tests"
+ ,(search-patch "libtool-skip-tests.patch"))))
+ (synopsis "GNU Libtool, a generic library support script")
+ (description
+ "GNU libtool is a generic library support script. Libtool hides the
+complexity of using shared libraries behind a consistent, portable interface.
+
+To use libtool, add the new generic library building commands to your
+Makefile, Makefile.in, or Makefile.am. See the documentation for
+details.")
+ (license "GPLv3+")
+ (home-page "http://www.gnu.org/software/libtool/")))
diff --git a/distro/packages/guile.scm b/distro/packages/guile.scm
index dce6ed863e..80e5ef7612 100644
--- a/distro/packages/guile.scm
+++ b/distro/packages/guile.scm
@@ -22,7 +22,7 @@
#:use-module (distro packages gawk)
#:use-module (distro packages gperf)
#:use-module (distro packages libffi)
- #:use-module (distro packages libtool)
+ #:use-module (distro packages autotools)
#:use-module (distro packages libunistring)
#:use-module (distro packages m4)
#:use-module (distro packages multiprecision)
diff --git a/distro/packages/libtool.scm b/distro/packages/libtool.scm
deleted file mode 100644
index 7d4f1aabf4..0000000000
--- a/distro/packages/libtool.scm
+++ /dev/null
@@ -1,56 +0,0 @@
-;;; Guix --- Nix package management from Guile. -*- coding: utf-8 -*-
-;;; Copyright (C) 2012 Ludovic Courtès <ludo@gnu.org>
-;;;
-;;; This file is part of Guix.
-;;;
-;;; Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (distro packages libtool)
- #:use-module (distro)
- #:use-module (distro packages m4)
- #:use-module (distro packages perl)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix utils)
- #:use-module (guix build-system gnu))
-
-(define-public libtool
- (package
- (name "libtool")
- (version "2.4.2")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/libtool/libtool-"
- version ".tar.gz"))
- (sha256
- (base32
- "0649qfpzkswgcj9vqkkr9rn4nlcx80faxpyqscy2k1x9c94f93dk"))))
- (build-system gnu-build-system)
- (native-inputs `(("m4" ,m4)
- ("perl" ,perl)))
- (arguments
- ;; TODO: Use `TESTSUITEFLAGS=-jN' for tests.
- `(#:patches (list (assoc-ref %build-inputs "patch/skip-tests"))))
- (inputs `(("patch/skip-tests"
- ,(search-patch "libtool-skip-tests.patch"))))
- (synopsis "GNU Libtool, a generic library support script")
- (description
- "GNU libtool is a generic library support script. Libtool hides the
-complexity of using shared libraries behind a consistent, portable interface.
-
-To use libtool, add the new generic library building commands to your
-Makefile, Makefile.in, or Makefile.am. See the documentation for
-details.")
- (license "GPLv3+")
- (home-page "http://www.gnu.org/software/libtool/")))