summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Sturmfels <ben@sturm.com.au>2024-06-17 16:29:01 +1000
committerjgart <jgart@dismail.de>2024-06-17 17:15:14 -0500
commit313a3c17e78528afbe743e04c4aa04bc489d70aa (patch)
tree2d950cd8fd413fc0c198c727b8a692b4ccecf72b
parent2a499ada726dd2a337d1d85641a2ebacef69336f (diff)
downloadguix-patches-313a3c17e78528afbe743e04c4aa04bc489d70aa.tar
guix-patches-313a3c17e78528afbe743e04c4aa04bc489d70aa.tar.gz
gnu: python-pyld: Update to 2.0.4.
* gnu/packages/python-xyz.scm (python-pyld): Update to 2.0.4. Change-Id: Iebd823a94c8f39944162056d451176d112e229e3 Signed-off-by: jgart <jgart@dismail.de>
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c98453039b..ad4630d9c1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5411,18 +5411,19 @@ files.")
(define-public python-pyld
(package
(name "python-pyld")
- (version "1.0.5")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "PyLD" version))
- (sha256
- (base32
- "1ywbdbsrkg533qh8xn9ifjh2mvam6v5msrjyqq73jfpvcp89qvff"))))
+ (version "2.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "PyLD" version))
+ (sha256
+ (base32 "1k7ars8n6kramkvadxgy0qfsi5g1hipyha4wqw8l75mw1l7ka7ii"))))
(build-system python-build-system)
+ (native-inputs (list python-lxml))
+ (propagated-inputs (list python-cachetools python-frozendict))
(home-page "https://github.com/digitalbazaar/pyld")
(synopsis "Python implementation of the JSON-LD specification")
- (description
- "PyLD is an implementation of the JSON-LD specification.")
+ (description "PyLD is an implementation of the JSON-LD specification.")
(license license:bsd-3)))
(define-public python-cli-helpers