summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorarkhan <arkhan@riseup.net>2022-05-11 16:04:40 -0500
committerLudovic Courtès <ludo@gnu.org>2022-05-13 17:39:11 +0200
commit2e6f4220cffc72f55f5390a57499e95fc9a03796 (patch)
tree9e7d08cdf166dedfc4bd32aaf2a447386250d50f
parent0932e97637c785010bc69411a261655a2f38ba72 (diff)
downloadguix-patches-2e6f4220cffc72f55f5390a57499e95fc9a03796.tar
guix-patches-2e6f4220cffc72f55f5390a57499e95fc9a03796.tar.gz
gnu: xonsh: Update to 0.12.4.
* gnu/packages/shells.scm (xonsh): Update to 0.12.4. [source](snippet): Substitute "xonsh/parsers/completion_context.py". [arguments]: Rewrite #:phases as a gexp. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/shells.scm22
1 files changed, 16 insertions, 6 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 00a0ef363d..9fe0ed8e27 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -545,13 +545,13 @@ ksh, and tcsh.")
(define-public xonsh
(package
(name "xonsh")
- (version "0.9.27")
+ (version "0.12.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "xonsh" version))
(sha256
- (base32 "1maz7yvb5py91n699yqsna81x2i25mvrqkrcn7h7870nxd87ral2"))
+ (base32 "0xlac84nsgs0052n2pw8np1smlgghrbd7p6yrcp7d5qh8zdr9lx3"))
(modules '((guix build utils)))
(snippet
`(begin
@@ -565,6 +565,7 @@ ksh, and tcsh.")
"xonsh/__amalgam__.py"
"xonsh/lexer.py"
"xonsh/parsers/base.py"
+ "xonsh/parsers/completion_context.py"
"xonsh/xonfig.py")
(("from xonsh\\.ply\\.(.*) import" _ module)
(format #f "from ~a import" module))
@@ -572,10 +573,19 @@ ksh, and tcsh.")
#t))))
(build-system python-build-system)
(arguments
- '(;; TODO Try running run the test suite.
- ;; See 'requirements-tests.txt' in the source distribution for more
- ;; information.
- #:tests? #f))
+ (list ;; TODO Try running run the test suite.
+ ;; See 'requirements-tests.txt' in the source distribution for more
+ ;; information.
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out")))
+ (invoke "python" "-m" "compileall"
+ "--invalidation-mode=unchecked-hash" out)
+ (invoke "python" "setup.py" "install" "--root=/"
+ (string-append "--prefix=" out))))))))
(inputs
(list python-ply))
(home-page "https://xon.sh/")