summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-17 16:42:01 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-17 22:24:03 -0500
commit2bf53290df8923ee9a9deeb3d4cb18cd4ff68ca1 (patch)
tree218472de97ae6a8357e98ad9c1861e8a6a61b4de
parentdece47497cc0da5672357b7b37fe15a956a78b01 (diff)
downloadguix-patches-2bf53290df8923ee9a9deeb3d4cb18cd4ff68ca1.tar
guix-patches-2bf53290df8923ee9a9deeb3d4cb18cd4ff68ca1.tar.gz
gnu: Add python-aiosignal.
* gnu/packages/python-web.scm (python-aiosignal): New variable.
-rw-r--r--gnu/packages/python-web.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index a73f0da35f..75126c5b40 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -193,6 +193,33 @@ implements @code{collections.abc.MutableSequence}. It can be made immutable
by calling @code{FrozenList.freeze}.")
(license license:asl2.0)))
+(define-public python-aiosignal
+ (package
+ (name "python-aiosignal")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "aiosignal" version))
+ (sha256
+ (base32 "1wkxbdgw07ay8yzx3pg1jcm46p3d21rfb5g4k17ysz3vdkdngvbq"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "tests")))))))
+ (propagated-inputs (list python-frozenlist))
+ (native-inputs (list python-pytest python-pytest-asyncio))
+ (home-page "https://github.com/aio-libs/aiosignal")
+ (synopsis "Callback manager for Python @code{asyncio} projects")
+ (description "This Python module provides @code{Signal}, an abstraction to
+register asynchronous callbacks. The @code{Signal} abstraction can be used
+for adding, removing and dropping callbacks.")
+ (license license:asl2.0)))
+
(define-public python-aiohttp
(package
(name "python-aiohttp")