summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2023-01-20 23:33:42 +0100
committerLudovic Courtès <ludo@gnu.org>2023-01-27 18:16:55 +0100
commit25b01ed77f2bff3d73fb9c8df1a0ce1bcab30d3c (patch)
treec1b5c476bfa8a3a32b600cb5fbb538570cd89064
parentf84fdb3d893662e654f84e01563e5c1b3d032115 (diff)
downloadguix-patches-25b01ed77f2bff3d73fb9c8df1a0ce1bcab30d3c.tar
guix-patches-25b01ed77f2bff3d73fb9c8df1a0ce1bcab30d3c.tar.gz
gnu: inkscape: Fix qrcode rendering.
Fixes <https://issues.guix.gnu.org/57479>. * gnu/packages/inkscape.scm (inkscape)[inputs]: Add python-cssselect. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/inkscape.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
index 2e43835e4f..d1ac5e7312 100644
--- a/gnu/packages/inkscape.scm
+++ b/gnu/packages/inkscape.scm
@@ -46,6 +46,7 @@
#:use-module (gnu packages pdf)
#:use-module (gnu packages popt)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages xml)
#:use-module (gnu packages ghostscript)
@@ -273,5 +274,6 @@ as the native format.")
(inputs (modify-inputs (package-inputs inkscape/stable)
(replace "lib2geom" lib2geom-1.2)
(append bash-minimal
- librsvg))) ;for the pixbuf loader
+ librsvg ;for the pixbuf loader
+ python-cssselect))) ;to render qrcode
(properties (alist-delete 'hidden? (package-properties inkscape/stable)))))