summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2022-05-07 08:37:32 +0000
committerLudovic Courtès <ludo@gnu.org>2022-05-13 17:15:54 +0200
commit2200530bf6850c381f455b3b0d349a9afb2aa2e9 (patch)
treee84b966e71e42726455d5b8241907e682f26e707
parent89a2eb25c3e9809eb58ce48d4f36bf06bad338dc (diff)
downloadguix-patches-2200530bf6850c381f455b3b0d349a9afb2aa2e9.tar
guix-patches-2200530bf6850c381f455b3b0d349a9afb2aa2e9.tar.gz
gnu: openssl: Use $SSL_CERT_DIR/$SSL_CERT_FILE.
* gnu/packages/tls.scm (openssl)[native-search-paths]: Use the $SSL_CERT_DIR/$SSL_CERT_FILE from (guix search-paths) instead of a local copy. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/tls.scm11
1 files changed, 2 insertions, 9 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 84ed0caa5d..e413f3c24f 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -51,6 +51,7 @@
#:use-module (guix build-system python)
#:use-module (guix build-system cmake)
#:use-module (guix build-system trivial)
+ #:use-module ((guix search-paths) #:select ($SSL_CERT_DIR $SSL_CERT_FILE))
#:use-module (gnu packages compression)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
@@ -495,15 +496,7 @@ OpenSSL for TARGET."
#$(package-version this-package)
"/misc")))))))
(native-search-paths
- (list (search-path-specification
- (variable "SSL_CERT_DIR")
- (separator #f) ;single entry
- (files '("etc/ssl/certs")))
- (search-path-specification
- (variable "SSL_CERT_FILE")
- (file-type 'regular)
- (separator #f) ;single entry
- (files '("etc/ssl/certs/ca-certificates.crt")))))
+ (list $SSL_CERT_DIR $SSL_CERT_FILE))
(synopsis "SSL/TLS implementation")
(description
"OpenSSL is an implementation of SSL/TLS.")