summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-07-21 15:22:22 +0200
committerMarius Bakke <marius@gnu.org>2022-07-23 19:43:10 +0200
commit1ecf710caed394e066aa0e5a74aa5128d777a329 (patch)
tree8ecd735272dd672cce0a78e646ce7e09a2d53df3
parent093f13610bf50762040696b320b69f6e9376ef34 (diff)
downloadguix-patches-1ecf710caed394e066aa0e5a74aa5128d777a329.tar
guix-patches-1ecf710caed394e066aa0e5a74aa5128d777a329.tar.gz
gnu: cyrus-sasl: Fix indentation.
* gnu/packages/cyrus-sasl.scm (cyrus-sasl): Reindent.
-rw-r--r--gnu/packages/cyrus-sasl.scm62
1 files changed, 32 insertions, 30 deletions
diff --git a/gnu/packages/cyrus-sasl.scm b/gnu/packages/cyrus-sasl.scm
index 43694ff5f3..33c054a097 100644
--- a/gnu/packages/cyrus-sasl.scm
+++ b/gnu/packages/cyrus-sasl.scm
@@ -34,42 +34,44 @@
(define-public cyrus-sasl
(package
- (name "cyrus-sasl")
- (version "2.1.28")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/cyrusimap/cyrus-sasl"
- "/releases/download/cyrus-sasl-" version
- "/cyrus-sasl-" version ".tar.gz"))
- (sha256 (base32
- "135kbgyfpa1mwqp5dm223yr6ddzi4vjm7cr414d7rmhys2mwdkvw"))))
- (build-system gnu-build-system)
- (inputs (list gdbm openssl))
- (propagated-inputs
- (list ;; cyrus-sasl.pc refers to -lkrb5, so propagate it.
- mit-krb5))
- (arguments
- (list
- #:configure-flags #~(list (string-append "--with-plugindir="
- #$output "/lib/sasl2")
- ;; When cross-compiling the build system is
- ;; unable to determine whether SPNEGO is
- ;; supported; Kerberos does, so enable it.
- #$@(if (%current-target-system)
- '("ac_cv_gssapi_supports_spnego=yes")
- '()))
+ (name "cyrus-sasl")
+ (version "2.1.28")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/cyrusimap/cyrus-sasl"
+ "/releases/download/cyrus-sasl-" version
+ "/cyrus-sasl-" version ".tar.gz"))
+ (sha256
+ (base32
+ "135kbgyfpa1mwqp5dm223yr6ddzi4vjm7cr414d7rmhys2mwdkvw"))))
+ (build-system gnu-build-system)
+ (inputs (list gdbm openssl))
+ (propagated-inputs
+ ;; cyrus-sasl.pc refers to -lkrb5, so propagate it.
+ (list mit-krb5))
+ (arguments
+ (list
+ #:configure-flags #~(list (string-append "--with-plugindir="
+ (assoc-ref %outputs "out")
+ "/lib/sasl2")
+ ;; When cross-compiling the build system is
+ ;; unable to determine whether SPNEGO is
+ ;; supported; Kerberos does, so enable it.
+ #$@(if (%current-target-system)
+ '("ac_cv_gssapi_supports_spnego=yes")
+ '()))
;; The 'plugins' directory has shared source files, such as
;; 'plugin_common.c'. When building the shared libraries there, libtool
;; ends up doing "ln -s plugin_common.lo plugin_common.o", which can
;; fail with EEXIST when building things in parallel.
#:parallel-build? #f))
- (synopsis "Simple Authentication Security Layer implementation")
- (description
- "SASL (Simple Authentication Security Layer) is an Internet
+ (synopsis "Simple Authentication Security Layer implementation")
+ (description
+ "SASL (Simple Authentication Security Layer) is an Internet
standards-track method for remote computers to authenticate. The Cyrus SASL
library makes supporting various SASL mechanisms easy for both client and
server writers.")
- (license (license:non-copyleft "file://COPYING"
- "See COPYING in the distribution."))
- (home-page "https://cyrusimap.org/sasl/")))
+ (license (license:non-copyleft "file://COPYING"
+ "See COPYING in the distribution."))
+ (home-page "https://cyrusimap.org/sasl/")))