summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-08-22 10:45:11 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-08-22 12:34:20 -0400
commit13425768f7c393cda49302ba2e8705f14ae56f0d (patch)
tree4f3bb4c06b4dee4b59c5585272e1450d021ccd4c
parent206b357c01b35a3aabbcfb2b69c5102d96723916 (diff)
downloadguix-patches-13425768f7c393cda49302ba2e8705f14ae56f0d.tar
guix-patches-13425768f7c393cda49302ba2e8705f14ae56f0d.tar.gz
gnu: ibus-anthy: Update to 1.5.15.
* gnu/packages/ibus.scm (ibus-anthy): Update to 1.5.15. * gnu/packages/patches/ibus-anthy-fix-tests.patch: Update patch.
-rw-r--r--gnu/packages/ibus.scm6
-rw-r--r--gnu/packages/patches/ibus-anthy-fix-tests.patch16
2 files changed, 14 insertions, 8 deletions
diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index c3310ec2a3..f9ef44a6d9 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -349,7 +349,7 @@ Chinese pinyin input methods.")
(define-public ibus-anthy
(package
(name "ibus-anthy")
- (version "1.5.14")
+ (version "1.5.15")
(source (origin
(method url-fetch)
(uri (string-append
@@ -357,13 +357,13 @@ Chinese pinyin input methods.")
version "/ibus-anthy-" version ".tar.gz"))
(sha256
(base32
- "16vd0k8wm13s38869jqs3dnwmjvywgn0snnpyi41m28binhlssf8"))
+ "12yrgqiq6mqc8jr49dgkk3d7mdnyqic4xs597biwjjkahgaydi2q"))
(patches (search-patches "ibus-anthy-fix-tests.patch"))))
(build-system glib-or-gtk-build-system)
(arguments
(list
;; The test suite hangs (see:
- ;; https://github.com/ibus/ibus-anthy/issues/28).
+ ;; https://github.com/ibus/ibus-anthy/pull/35).
#:tests? #f
#:configure-flags
;; Use absolute exec path in the anthy.xml.
diff --git a/gnu/packages/patches/ibus-anthy-fix-tests.patch b/gnu/packages/patches/ibus-anthy-fix-tests.patch
index 6934358980..c8b2b4211e 100644
--- a/gnu/packages/patches/ibus-anthy-fix-tests.patch
+++ b/gnu/packages/patches/ibus-anthy-fix-tests.patch
@@ -1,17 +1,14 @@
Submitted upstream: https://github.com/ibus/ibus-anthy/pull/35
diff --git a/tests/test-build.sh b/tests/test-build.sh
-index e83b78f..a0efe32 100755
+index e83b78f..bbfa7e1 100755
--- a/tests/test-build.sh
+++ b/tests/test-build.sh
-@@ -63,26 +63,27 @@ parse_args()
+@@ -63,26 +63,33 @@ parse_args()
done;
}
+maybe_install_pycotap() {
-+ # Check if pycotap is already available.
-+ python3 -m pycotap >/dev/null && return 0
-+
+ # Red Hat specific hint.
+ if test -f /etc/redhat-release ; then
+ if ! rpm -q --quiet python3-pycotap; then
@@ -19,6 +16,15 @@ index e83b78f..a0efe32 100755
+ exit -1
+ fi
+ fi;
++
++ # Check if pycotap is already available.
++ if ! python3 -m pycotap >/dev/null; then
++ echo "pycotap not found; installing via pip"
++ if ! pip install pycotap --user; then
++ echo "failed to install pycotap"
++ exit -1
++ fi
++ fi
+}
+
init_environment()