summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-12-16 20:58:51 +0100
committerMarius Bakke <marius@gnu.org>2021-12-16 22:21:13 +0100
commit12c75628b4322853943ae0d0a833e371c02b97f4 (patch)
tree8dd27f5838abaeb9dcaf52b184c75c37d97fc942
parent3dcf972944b1ee3d09ca03493fbbb30a87d58282 (diff)
downloadguix-patches-12c75628b4322853943ae0d0a833e371c02b97f4.tar
guix-patches-12c75628b4322853943ae0d0a833e371c02b97f4.tar.gz
gnu: file: Add 5.41.
* gnu/packages/file.scm (file-next): New variable.
-rw-r--r--gnu/packages/file.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/file.scm b/gnu/packages/file.scm
index 1c330e5434..5e379d888b 100644
--- a/gnu/packages/file.scm
+++ b/gnu/packages/file.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2021 Marius Bakke <marius@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -57,3 +58,15 @@ extensions to tell you the type of a file, but looks at the actual contents
of the file. This package provides the libmagic library.")
(license bsd-2)
(home-page "https://www.darwinsys.com/file/")))
+
+(define-public file-next
+ (package
+ (inherit file)
+ (version "5.41")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://ftp.astron.com/pub/file/file-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0gv027jgdr0hdkw7m9ck0nwhq583f4aa7vnz4dzdbxv4ng3k5r8k"))))))