summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-09 16:16:47 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-09 17:14:52 +0100
commit0f3f787043ab0aa01b2fc3679c2e72ed70675ba3 (patch)
tree70ee95ea5286a35755d834e9cf478780ce1ce1fd
parente8d3d5224ebd200a025a514a558fb63c60701332 (diff)
downloadguix-patches-0f3f787043ab0aa01b2fc3679c2e72ed70675ba3.tar
guix-patches-0f3f787043ab0aa01b2fc3679c2e72ed70675ba3.tar.gz
gnu: csvdiff: Adjust inputs.
* gnu/packages/textutils.scm (csvdiff): Adjust inputs. [arguments]: Swap to list style, do not install sources. [native-inputs]: Swap from propagated-inputs to native-inputs. Remove indirect Golang modules: go-github-com-mattn-go-colorable, go-github-com-oneofone-xxhash, go-github-com-spaolacci-murmur3, and go-golang-org-x-sys. Change-Id: I903d8869b8c468c15a2e78a565bcaaf34594e34b
-rw-r--r--gnu/packages/textutils.scm18
1 files changed, 8 insertions, 10 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index e5cb96d524..b87c65cb89 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -1505,17 +1505,15 @@ files for valid UTF-8 use and to report which line endings they use.")
"0cd1ikxsypjqisfnmr7zix3g7x8p892w77086465chyd39gpk97b"))))
(build-system go-build-system)
(arguments
- '(#:import-path "github.com/aswinkarthik/csvdiff"))
- (propagated-inputs
- (list go-golang-org-x-sys
- go-github-com-stretchr-testify
- go-github-com-spf13-cobra
- go-github-com-spf13-afero
- go-github-com-spaolacci-murmur3
- go-github-com-mattn-go-colorable
+ (list
+ #:install-source? #f
+ #:import-path "github.com/aswinkarthik/csvdiff"))
+ (native-inputs
+ (list go-github-com-cespare-xxhash
go-github-com-fatih-color
- go-github-com-cespare-xxhash
- go-github-com-oneofone-xxhash))
+ go-github-com-spf13-afero
+ go-github-com-spf13-cobra
+ go-github-com-stretchr-testify))
(home-page "https://github.com/aswinkarthik/csvdiff")
(synopsis "Fast diff tool for comparing CSV files")
(description "@code{csvdiff} is a diff tool to compute changes between two