summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-09-28 21:58:26 +0200
committerLudovic Courtès <ludo@gnu.org>2015-09-28 22:54:04 +0200
commit0b1f0d36b1219710d6e9e1cd15fbabe729d374e0 (patch)
treeec0f4dac3487ecff55f5eea3c372f02697421f9f
parent30d9aa54229b413e52a2ed00032fa5179e4905ec (diff)
downloadguix-patches-0b1f0d36b1219710d6e9e1cd15fbabe729d374e0.tar
guix-patches-0b1f0d36b1219710d6e9e1cd15fbabe729d374e0.tar.gz
gnu: lsh: 'lsh-authorize' uses the absolute file name of 'sexp-conv'.
Fixes <http://bugs.gnu.org/21516>. Reported by Andreas Enge <andreas@enge.fr>. * gnu/packages/lsh.scm (lsh)[arguments]: In 'pre-configure' phase, change 'src/lsh-authorize' to use the absolute file name of 'sexp-conv'.
-rw-r--r--gnu/packages/lsh.scm19
1 files changed, 12 insertions, 7 deletions
diff --git a/gnu/packages/lsh.scm b/gnu/packages/lsh.scm
index 0edf6b4382..e034d66940 100644
--- a/gnu/packages/lsh.scm
+++ b/gnu/packages/lsh.scm
@@ -116,14 +116,19 @@ basis for almost any application.")
(alist-cons-before
'configure 'pre-configure
(lambda* (#:key inputs #:allow-other-keys)
- ;; Make sure 'lsh' and 'lshd' pick 'sexp-conv' in the right place by
- ;; default.
- (substitute* "src/environ.h.in"
- (("^#define PATH_SEXP_CONV.*")
- (let* ((nettle (assoc-ref inputs "nettle"))
- (sexp-conv (string-append nettle "/bin/sexp-conv")))
+ (let* ((nettle (assoc-ref inputs "nettle"))
+ (sexp-conv (string-append nettle "/bin/sexp-conv")))
+ ;; Make sure 'lsh' and 'lshd' pick 'sexp-conv' in the right place
+ ;; by default.
+ (substitute* "src/environ.h.in"
+ (("^#define PATH_SEXP_CONV.*")
(string-append "#define PATH_SEXP_CONV \""
- sexp-conv "\"\n"))))
+ sexp-conv "\"\n")))
+
+ ;; Same for the 'lsh-authorize' script.
+ (substitute* "src/lsh-authorize"
+ (("=sexp-conv")
+ (string-append "=" sexp-conv))))
;; Tests rely on $USER being set.
(setenv "USER" "guix"))