summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-05-28 22:19:56 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-05-28 22:23:32 +0300
commit0542905a2c5cb4f645399e19c2a4924dc757057e (patch)
treec6642f0181c60cd567496608fdfd7d17d485a654
parent81803c5eaae4ac6d48415a47b5d92de7a9e18b1a (diff)
downloadguix-patches-0542905a2c5cb4f645399e19c2a4924dc757057e.tar
guix-patches-0542905a2c5cb4f645399e19c2a4924dc757057e.tar.gz
gnu: wget2: Reindent package.
* gnu/packages/wget.scm (wget2): Reindent package with 'guix style'.
-rw-r--r--gnu/packages/wget.scm76
1 files changed, 37 insertions, 39 deletions
diff --git a/gnu/packages/wget.scm b/gnu/packages/wget.scm
index f5b7a5b91f..7c8c961dfb 100644
--- a/gnu/packages/wget.scm
+++ b/gnu/packages/wget.scm
@@ -134,42 +134,40 @@ online pastebin services.")
(define-public wget2
(package
- (name "wget2")
- (version "2.0.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/wget/wget2-" version ".tar.gz"))
- (sha256
- (base32
- "1caxhkwk08z3npzw8x2qhkmjc224cfw1aphvbv8bidbvd41zmdqb"))))
- (build-system gnu-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'skip-network-tests
- (lambda _
- (substitute* "tests/Makefile.in"
- (("test-gpg-verify-no-file\\$\\(EXEEXT)") "")
- (("test-gpg-valid\\$\\(EXEEXT)") "")
- (("test-gpg-styles\\$\\(EXEEXT)") "")))))
- #:configure-flags '("--enable-static=no")))
- (inputs
- (list bzip2
- gnutls/dane
- gpgme
- libidn2
- libmicrohttpd
- libpsl
- pcre2
- zlib))
- ;; TODO: Add libbrotlidec, libnghttp2.
- (native-inputs
- (list pkg-config))
- (home-page "https://gitlab.com/gnuwget/wget2")
- (synopsis "Successor of GNU Wget")
- (description "GNU Wget2 is the successor of GNU Wget, a file and recursive
-website downloader. Designed and written from scratch it wraps around libwget,
-that provides the basic functions needed by a web client.")
- (properties '((ftp-directory . "/gnu/wget")))
- (license (list license:gpl3+ license:lgpl3+))))
+ (name "wget2")
+ (version "2.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/wget/wget2-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1caxhkwk08z3npzw8x2qhkmjc224cfw1aphvbv8bidbvd41zmdqb"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'skip-network-tests
+ (lambda _
+ (substitute* "tests/Makefile.in"
+ (("test-gpg-verify-no-file\\$\\(EXEEXT)") "")
+ (("test-gpg-valid\\$\\(EXEEXT)") "")
+ (("test-gpg-styles\\$\\(EXEEXT)") "")))))
+ #:configure-flags
+ '("--enable-static=no")))
+ (inputs (list bzip2
+ gnutls/dane
+ gpgme
+ libidn2
+ libmicrohttpd
+ libpsl
+ pcre2
+ zlib))
+ ;; TODO: Add libbrotlidec, libnghttp2.
+ (native-inputs (list pkg-config))
+ (home-page "https://gitlab.com/gnuwget/wget2")
+ (synopsis "Successor of GNU Wget")
+ (description
+ "GNU Wget2 is the successor of GNU Wget, a file and recursive website
+downloader. Designed and written from scratch it wraps around libwget, that
+provides the basic functions needed by a web client.")
+ (properties '((ftp-directory . "/gnu/wget")))
+ (license (list license:gpl3+ license:lgpl3+))))