summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Acereda <jacereda@gmail.com>2024-05-09 12:10:25 +0200
committerGuix Patches Tester <>2024-05-09 12:05:52 +0200
commitbf64b505632ef9371ef050a620dc3b64285697a6 (patch)
tree540c01a5a78ad0d99a34e8076a37105076db686b
parent7b7f299bb493e485c5534b8c554e51d4f3a8c026 (diff)
downloadguix-patches-issue-70837.tar
guix-patches-issue-70837.tar.gz
gnu: Add decker.issue-70837
Change-Id: Id0879002f9ce0928051dda40ba0dc7bc233ea439
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/decker.scm72
2 files changed, 73 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index edd546f81d..f5d3785f5f 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -232,6 +232,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/debug.scm \
%D%/packages/dejagnu.scm \
%D%/packages/dezyne.scm \
+ %D%/packages/decker.scm \
%D%/packages/dhall.scm \
%D%/packages/dico.scm \
%D%/packages/dictionaries.scm \
diff --git a/gnu/packages/decker.scm b/gnu/packages/decker.scm
new file mode 100644
index 0000000000..c5c317f770
--- /dev/null
+++ b/gnu/packages/decker.scm
@@ -0,0 +1,72 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2024 Jorge Acereda <jacereda@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+
+(define-module (gnu packages decker)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages sdl)
+ #:use-module (gnu packages vim)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix gexp)
+ #:use-module (guix git-download)
+ #:use-module (guix packages))
+
+(define-public decker
+ (package
+ (name "decker")
+ (version "1.41")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JohnEarnest/Decker")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0nmhqgqxcgaw6yyxn0xn9zqwjb4kqqqmgrlfnswm7zksmw0qax82"))))
+ (build-system gnu-build-system)
+ (inputs
+ (list
+ (sdl-union
+ (list
+ sdl2-image
+ sdl2))))
+ (native-inputs
+ (list
+ xxd))
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda _
+ (invoke "make" "lilt" "decker")))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (lambda _
+ (invoke "test")))))
+ (replace 'install
+ (lambda _
+ (invoke "make" "install" (string-append "PREFIX=" #$output)))))))
+ (home-page "http://beyondloom.com/decker/")
+ (synopsis "Multimedia sketchpad")
+ (description "Decker is a multimedia platform for creating and sharing interactive
+documents, with sound, images, hypertext, and scripted behavior.")
+ (license license:expat)))