summaryrefslogtreecommitdiff
path: root/po/doc/local.mk
diff options
context:
space:
mode:
Diffstat (limited to 'po/doc/local.mk')
-rw-r--r--po/doc/local.mk11
1 files changed, 10 insertions, 1 deletions
diff --git a/po/doc/local.mk b/po/doc/local.mk
index ca588ea916..6b934d945a 100644
--- a/po/doc/local.mk
+++ b/po/doc/local.mk
@@ -16,9 +16,13 @@
# You should have received a copy of the GNU General Public License
# along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+DOC_PO_FILES= \
+ %D%/guix-manual.de.po \
+ %D%/guix-manual.fr.po
+
EXTRA_DIST = \
%D%/guix-manual.pot \
- %D%/guix-manual.fr.po
+ $(DOC_PO_FILES)
POT_OPTIONS = --package-name "guix" --package-version "$(VERSION)" \
--copyright-holder "Ludovic Courtès" \
@@ -57,3 +61,8 @@ doc-pot-update:
done
msgcat $(addprefix $(srcdir)/po/doc/, $(TMP_POT_FILES)) > $(srcdir)/po/doc/guix-manual.pot
rm -f $(addprefix $(srcdir)/po/doc/, $(TMP_POT_FILES))
+
+doc-po-update: doc-pot-update
+ for f in $(DOC_PO_FILES); do \
+ $(MAKE) "$$f"; \
+ done