summaryrefslogtreecommitdiff
path: root/guix
diff options
context:
space:
mode:
Diffstat (limited to 'guix')
-rw-r--r--guix/build-system/pyproject.scm2
-rw-r--r--guix/build/pyproject-build-system.scm12
2 files changed, 8 insertions, 6 deletions
diff --git a/guix/build-system/pyproject.scm b/guix/build-system/pyproject.scm
index 1e365d4f21..8f3b562ca3 100644
--- a/guix/build-system/pyproject.scm
+++ b/guix/build-system/pyproject.scm
@@ -95,7 +95,7 @@
(configure-flags ''())
(build-backend #f)
(test-backend #f)
- (test-flags #f)
+ (test-flags ''())
(phases '%standard-phases)
(outputs '("out" "wheel"))
(search-paths '())
diff --git a/guix/build/pyproject-build-system.scm b/guix/build/pyproject-build-system.scm
index b969dd0379..c69ccc9d64 100644
--- a/guix/build/pyproject-build-system.scm
+++ b/guix/build/pyproject-build-system.scm
@@ -158,14 +158,16 @@ builder.build_wheel(sys.argv[2], config_settings=config_settings)"
(format #t "Using ~a~%" use-test-backend)
(match use-test-backend
('pytest
- (apply invoke (cons pytest (or test-flags '("-vv")))))
+ (apply invoke pytest "-vv" test-flags))
('nose
- (apply invoke (cons nosetests (or test-flags '("-v")))))
+ (apply invoke nosetests "-v" test-flags))
('nose2
- (apply invoke (cons nose2 (or test-flags '("-v" "--pretty-assert")))))
+ (apply invoke nose2 "-v" "--pretty-assert" test-flags))
('setup.py
- (apply invoke (append '("python" "setup.py")
- (or test-flags '("test" "-v")))))
+ (apply invoke "python" "setup.py"
+ (if (null? test-flags)
+ '("test" "-v")
+ test-flags)))
;; The developer should explicitly disable tests in this case.
(else (raise (condition (&test-system-not-found))))))
(format #t "test suite not run~%")))