summaryrefslogtreecommitdiff
path: root/guix/licenses.scm
diff options
context:
space:
mode:
Diffstat (limited to 'guix/licenses.scm')
-rw-r--r--guix/licenses.scm27
1 files changed, 22 insertions, 5 deletions
diff --git a/guix/licenses.scm b/guix/licenses.scm
index bf72a33c92..255b755e6c 100644
--- a/guix/licenses.scm
+++ b/guix/licenses.scm
@@ -14,6 +14,8 @@
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2020 André Batista <nandre@riseup.net>
+;;; Copyright © 2020 Helio Machado <0x2b3bfa0+guix@googlemail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -34,6 +36,7 @@
#:use-module (srfi srfi-9)
#:export (license? license-name license-uri license-comment
agpl1 agpl3 agpl3+
+ apsl2
asl1.1 asl2.0
boost1.0
bsd-2 bsd-3 bsd-4
@@ -47,6 +50,7 @@
artistic2.0 clarified-artistic
copyleft-next
cpl1.0
+ cua-opl1.0
edl1.0
epl1.0
epl2.0
@@ -74,7 +78,7 @@
mpl1.0 mpl1.1 mpl2.0
ms-pl
ncsa
- nmap
+ npsl
ogl-psi1.0
openldap2.8 openssl
perl-license
@@ -115,6 +119,9 @@
;;; https://github.com/NixOS/nixpkgs/blob/master/lib/licenses.nix
;;; https://www.gnu.org/licenses/license-list
;;;
+;;; Please update spdx-string->license from guix/import/utils.scm
+;;; when modifying this list to avoid mismatches.
+;;;
;;; Code:
(define agpl1
@@ -132,6 +139,11 @@
"https://gnu.org/licenses/agpl.html"
"https://gnu.org/licenses/why-affero-gpl.html"))
+(define apsl2
+ (license "APSL 2.0"
+ "https://directory.fsf.org/wiki/License:APSL-2.0"
+ "https://www.gnu.org/licenses/license-list.html#apsl2"))
+
(define asl1.1
(license "ASL 1.1"
"http://directory.fsf.org/wiki/License:Apache1.1"
@@ -262,6 +274,11 @@ at URI, which may be a file:// URI pointing the package's tree."
"http://directory.fsf.org/wiki/License:CPLv1.0"
"https://www.gnu.org/licenses/license-list#CommonPublicLicense10"))
+(define cua-opl1.0
+ (license "CUA Office Public License v1.0"
+ "https://spdx.org/licenses/CUA-OPL-1.0.html"
+ "https://opensource.org/licenses/CUA-OPL-1.0"))
+
(define edl1.0
(license "EDL 1.0"
"http://directory.fsf.org/wiki/License:EDLv1.0"
@@ -514,10 +531,10 @@ at URI, which may be a file:// URI pointing the package's tree."
"http://directory.fsf.org/wiki/License:IllinoisNCSA"
"https://www.gnu.org/licenses/license-list#NCSA"))
-(define nmap
- (license "Nmap license"
- "https://svn.nmap.org/nmap/COPYING"
- "https://fedoraproject.org/wiki/Licensing/Nmap"))
+(define npsl
+ (license "Nmap Public Source License"
+ "https://svn.nmap.org/nmap/LICENSE"
+ "https://nmap.org/npsl/"))
(define ogl-psi1.0
(license "Open Government Licence for Public Sector Information"