summaryrefslogtreecommitdiff
path: root/guix/build/gnu-build-system.scm
diff options
context:
space:
mode:
Diffstat (limited to 'guix/build/gnu-build-system.scm')
-rw-r--r--guix/build/gnu-build-system.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/guix/build/gnu-build-system.scm b/guix/build/gnu-build-system.scm
index b67918552c..5e899403e8 100644
--- a/guix/build/gnu-build-system.scm
+++ b/guix/build/gnu-build-system.scm
@@ -98,7 +98,7 @@
(when (file-exists? "po/Makefile.in.in")
(substitute* "po/Makefile.in.in"
(("^SHELL[[:blank:]]*=.*$")
- (string-append "SHELL = " bash))))))
+ (string-append "SHELL = " bash "\n"))))))
(define* (patch #:key (patches '()) (patch-flags '("--batch" "-p1"))
#:allow-other-keys)
@@ -249,7 +249,7 @@
;; Standard build phases, as a list of symbol/procedure pairs.
(let-syntax ((phases (syntax-rules ()
((_ p ...) `((p . ,p) ...)))))
- (phases set-paths unpack patch-source-shebangs patch configure
+ (phases set-paths unpack patch patch-source-shebangs configure
build check install
patch-shebangs strip)))