summaryrefslogtreecommitdiff
path: root/guix/build-system
diff options
context:
space:
mode:
Diffstat (limited to 'guix/build-system')
-rw-r--r--guix/build-system/meson.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/guix/build-system/meson.scm b/guix/build-system/meson.scm
index dae0abde94..dcad3f322d 100644
--- a/guix/build-system/meson.scm
+++ b/guix/build-system/meson.scm
@@ -212,7 +212,10 @@ has a 'meson.build' file."
(map search-path-specification->sexp
search-paths))
#:phases build-phases
- #:configure-flags #$(sexp->gexp configure-flags)
+ #:configure-flags
+ #$(if (pair? configure-flags)
+ (sexp->gexp configure-flags)
+ configure-flags)
#:build-type #$build-type
#:tests? #$tests?
#:test-target #$test-target
@@ -309,7 +312,9 @@ SOURCE has a 'meson.build' file."
#:phases build-phases
#:make-dynamic-linker-cache? #$make-dynamic-linker-cache?
#:configure-flags `("--cross-file" #+cross-file
- ,@#$(sexp->gexp configure-flags))
+ ,@#$(if (pair? configure-flags)
+ (sexp->gexp configure-flags)
+ configure-flags))
#:build-type #$build-type
#:tests? #$tests?
#:test-target #$test-target