summaryrefslogtreecommitdiff
path: root/guix/build-system/qt.scm
diff options
context:
space:
mode:
Diffstat (limited to 'guix/build-system/qt.scm')
-rw-r--r--guix/build-system/qt.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/guix/build-system/qt.scm b/guix/build-system/qt.scm
index ccee89d5ef..003a065aa6 100644
--- a/guix/build-system/qt.scm
+++ b/guix/build-system/qt.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24,6 +25,8 @@
#:use-module (guix utils)
#:use-module (guix gexp)
#:use-module (guix monads)
+ #:use-module ((guix build qt-utils)
+ #:select (%qt-wrap-excluded-inputs))
#:use-module (guix search-paths)
#:use-module (guix build-system)
#:use-module (guix build-system cmake)
@@ -54,6 +57,7 @@
(define %qt-build-system-modules
;; Build-side modules imported and used by default.
`((guix build qt-build-system)
+ (guix build qt-utils)
,@%cmake-build-system-modules))
(define (default-cmake)
@@ -125,6 +129,7 @@
"bin" "sbin"))
(phases '%standard-phases)
(qt-wrap-excluded-outputs ''())
+ (qt-wrap-excluded-inputs %qt-wrap-excluded-inputs)
(system (%current-system))
(imported-modules %qt-build-system-modules)
(modules '((guix build qt-build-system)
@@ -146,6 +151,7 @@ provides a 'CMakeLists.txt' file as its build system."
(sexp->gexp phases)
phases)
#:qt-wrap-excluded-outputs #$qt-wrap-excluded-outputs
+ #:qt-wrap-excluded-inputs #$qt-wrap-excluded-inputs
#:configure-flags #$configure-flags
#:make-flags #$make-flags
#:out-of-source? #$out-of-source?