summaryrefslogtreecommitdiff
path: root/guix/build-system/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'guix/build-system/python.scm')
-rw-r--r--guix/build-system/python.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/guix/build-system/python.scm b/guix/build-system/python.scm
index 03e587ba01..cf7ca7d3e1 100644
--- a/guix/build-system/python.scm
+++ b/guix/build-system/python.scm
@@ -120,8 +120,8 @@ provides a 'setup.py' file as its build system."
`(begin
(use-modules ,@modules)
(python-build #:name ,name
- #:source ,(if (and source (derivation-path? source))
- (derivation-path->output-path source)
+ #:source ,(if (derivation? source)
+ (derivation->output-path source)
source)
#:configure-flags ,configure-flags
#:system ,system