summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm23
1 files changed, 11 insertions, 12 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 1a524e0ecf..cc1e9f658e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7128,18 +7128,17 @@ bioinformatics file formats, sequence alignment, and more.")
(arguments
`(#:modules ((guix build utils))
#:builder
- (begin
- (use-modules (guix build utils))
- (let ((tar (assoc-ref %build-inputs "tar"))
- (bzip (assoc-ref %build-inputs "bzip2"))
- (out (assoc-ref %outputs "out"))
- (doc (assoc-ref %outputs "doc")))
- (setenv "PATH" (string-append tar "/bin:" bzip "/bin"))
- (invoke "tar" "xvf" (assoc-ref %build-inputs "source"))
- (chdir (string-append "seqan-library-" ,version))
- (copy-recursively "include" (string-append out "/include"))
- (copy-recursively "share" (string-append doc "/share"))
- #t))))
+ ,#~(begin
+ (use-modules (guix build utils))
+ (let ((tar #$(this-package-native-input "tar"))
+ (bzip #$(this-package-native-input "bzip2"))
+ (out #$output)
+ (doc #$output:doc))
+ (setenv "PATH" (string-append tar "/bin:" bzip "/bin"))
+ (invoke "tar" "xvf" #$(this-package-native-input "source"))
+ (chdir (string-append "seqan-library-" #$version))
+ (copy-recursively "include" (string-append out "/include"))
+ (copy-recursively "share" (string-append doc "/share"))))))
(native-inputs
`(("source" ,source)
("tar" ,tar)